QTouch说明文档

QTouch使用说明书

QTOUCH介绍 | 工程管理器介绍 | 绘制系统介绍
  • QTouch概述
  • QTouch主要特点
  • QTouch 设计原理
  • QTouch的安装
  • QTouch的快速入门
  • QTouch与modbus通讯测试
  • 概述
  • 工程文件操作
  • 查看操作
  • 工具操作
  • 数据操作
  • 帮助菜单
  • 系统参数
  • 概述
  • 画面文件操作
  • 编辑操作
  • 视图查看
  • 绘制工具
  • 图形操作
  • Z序操作
  • 字体设置
  • 图元实时关联
  • 图元脚本属性
QTOUCH与PLC的连接 | 设备选择 | 数据库配置
  • 概述
  • 西门子 (SIEMENS) PLC
  • 施耐德（MODICON）PLC
  • 欧姆龙(OMRON)PLC
  • 三菱(Mitsubishi) PLC
  • 概述
  • 配置串口设备
  • 配置网络设备
  • 配置总线设备
  • 配置OPC设备
  • 概述
  • 设备变量
  • 中间变量
  • 系统变量
数据库 | 驱动监视 | 系统函数
  • 概述
  • 实时数据库
  • 历史数据库
  • 概述
  • 驱动监视
  • 概述
  • 事件脚本
c语言编辑器
  • 概述
  • 新建工程
  • 编译
  • 编辑器的常用功能介绍


QTouch概述

QTouch介绍

1．QTouch介绍

1.1 QTouch概述

在当今工控行业软硬件平台多样化的今天，我们首度提出：用一套自动化系统软件兼容当前主流的处理器，以及跨越所有的操作系统平台，将嵌入式设备所提供的监视、控制、逻辑、转换等功能进行封装，用一套简易化的软件平台开放给用户。

QTouch跨平台组态软件就是基于这种理念，采用跨平台技术，完全能够实现这样的构想。目前，良好支持的处理器有：omap3517、omap3530，9G45、9G10，PXA270等，如下图：

支持当前所有的主流操作系统平台：ARM-Linux，WinXP/E，WinXP/Win2K，Win 7，Linux（redhat），Unix(Solaris10)等，如下图，其softPLC部分可以支持实时操作系统。

QTouch分为组态环境和运行环境，组态环境推荐运行于windows系统平台，方便用户组态工程，运行环境则可以运行到多种环境中，即跨平台运行。用户将组建好的工程通过网络或USB下载到运行设备中即可按组态工程运行。运行模式如下：

QTouch不仅可以运行到高性能的工控机平台，更可以运行到嵌入式设备平台，因此QTouch的运行效率非常高，对设备的性能要求非常低。其功能组成如下：

QTouch运行部件包括实时数据库、历史数据库、HMI系统、设备级通讯、开放数据接口、对I/O设备的广泛支持，用户可以利用QTouch组态软件的功能，构建一套最适合自己的应用系统，通过对现场数据的采集处理，以动画显示、报警处理、流程控制和报表输出等多种方式向用户提供解决实际工程问题的方案。

此外QTouch嵌入版还带有一个模拟/运行环境，用于对组态后的工程进行模拟和运行，方便用户对组态过程的调试。


QTouch开发环境

QTouch主要特点

1．QTouch介绍

1.2 QTouch主要特点

上位机组态极为简单。不需要编程，只需要简单的配置即可实现工程的组态。 画面元件非常丰富。提供大量的基础图元，具有矩形、圆形、直线、曲线、多边形、按钮等，多图元能够组合，多组合能够组成动画；提供图元库，可以自己制作并调用图元库。

功能强大。不仅作为HMI使用，更可以作为SCADA系统使用，提供完善的实时数据库，历史数据库，工程数据配置系统，报警，历史数据存盘，用户权限，驱动开发系统，控件开发系统，softPLC，并有远程数据监视、控制系统。

平台开放。提供标准的驱动接入接口，提供标准的控件接入接口，提供实时数据库和历史数据的远程监控接口，更提供设备驱动级数据监视。

运行系统执行效率高效、快速。实时数据采用共享内存技术，数据的更新是通过位置索引而来，数据刷新不消耗cpu资源，支持上万点的数据；图形采用双缓存技术，只刷新变化区域，不变化区域不消耗cpu资源。实时数据采用共享内存技术，数据的更新是通过位置索引而来，数据刷新不消耗cpu资源，支持上万点的数据；图形采用双缓存技术，只刷新变化区域，不变化区域不消耗cpu资源。

支持多种通讯模式、协议。支持串口、以太网，CANBus、ProfiBus等，支持多种PLC、IO设备协议。

完善的报表功能。报表由用户根据系统要求来设计和绘制，具有定时查询，手动查询等。

完善的报警体系。支持报警实时显示，支持报警历史查询。

完善的曲线显示。有实时曲线，历史曲线、条件曲线等。

完善的操作、控制、故障及相关信息记录。用户的登录、操作、控制等都记录到历史数据库中，高级别权限的用户可以查询操作、控制记录等，类似于机器的黑匣子。

支持远程监视、远程调试。HMI设备安装到现地，二次开发人员不要到现地就可以监视驱动通过情况、实时数据库数据，以及画面显示等。

总之，QTouch组态软件具有强大的功能，并且操作简单，易学易用，普通工程人员经过短时间的培训就能迅速掌握多数工程项目的设计和运行操作。


QTouch 的特点

QTouch 设计原理

1．QTouch介绍

1.3.1 QTouch 软件整体框架结构

工程管理器是一个上位机的集成开发环境。包含运行系统基本参数设定、实时数据库参数设定，参数保存成XML文件，包含一个设备管理单元，用于将设备库中的通讯程序通过配置生成到工程文件中，包含一个图形绘制系统，用于生成图形文件，包含一个梯形图编辑器，用于生成梯形图文件，包含用于远程管理和调试的实时数据库、历史数据库、驱动管理程序。

嵌入式部分包含：画面运行执行系统（ctrun）、实时数据库（RTDB）、历史数据库（HISDB）、设备驱运行程序、梯形图实时扫描解释程序。

1.3.2 三层数据结构

采用3层数据传输模型，具有高安全性、易于扩展、平台开放的特点。驱动程序为独立的应用程序，提供开发包，可以自由开发。驱动程序与实时数据的数据交换采用共享内存的方式进行。实时数据库为我们多年实践经验积累起来的标准实时数据库。具有数据刷新快速，执行效率高，资源消耗少，模型经典，平台开放等特点（可以达到几十ms的数据刷新速度）。实时数据库提供一个标准的modbusTCP通讯接口，用于实现现场监视、远程控制等功能。历史数据库采用轻量级的sqlite3关系数据库，不需要odbc支持，程序直接操作数据库，用户可以感觉不到历史数据库的存在。运行系统启动画面系统运行，为人机接口，通过共享内存从rtdb索引数据，人机接口处理完全与数据处理分开，各自独立运行，提升程序安全性。

1.3.3 共享内存数据映射原理

驱动程序根据配置文件开辟驱动共享内存区，通过内存标识号索引该内存区数据。驱动内存区数据定义为int型，向下兼容bit，uchar，char，word等数据类型，数据存放位置可以自由定义。实时数据库开辟实时数据共享内存区，数据类型为double，实时数据库通过驱动内存标识索引各个驱动内存数据，并根据实时数据库参数进行工程数据转换，对dword数据类型，驱动分高、低字节存放，实时数据库中整合成dword型。画面运行系统中不进行数据处理，只是通过数据内存编号索引该编号的实时数据库中的数据，用于更新画面上的显示，因此效率很高。画面控制部分，用户点击或触发控制后，画面将控制编号发送到实时数据库，实时数据将命令控制串下发到指定驱动程序中，驱动则执行控制命令。


首页 | FAQs | 工程管理器使用说明 | 绘制系统使用说明| 入门实例

QTouch使用领域

1．产品介绍

1.4 QTouch使用领域


QTouch的安装

1．产品介绍

1.4.1 软件的来源

可由随机光盘获取，也可进入QTouch网站 （http://www.sitcsys.com/down/Default.aspx）获取所有可用版本的软件安装包（包括中文简体、繁体及英文版）及最新软件更新档案。

1.4.2 运行的操作系统

Windows NT/Windows 2000 /Windows XP/Win7均可。

1.4.3 安装步骤(以QTouch_Beta_Setup.msi简体中文版安装为例)

具体安装步骤如下：
双击setup.msi；
会自动弹出QTouch组态软件安装界面，如图：

点击下一步

单击“下一步”，安装程序将提示你指定安装的目录，如果用户没有指定，系统缺省安装到C:\Qtouch\目录下，建议使用缺省安装目录，

如上图所示：

单击“安装”
安装过程将持续数分钟。
单击完成后，Windows操作系统的桌面上会添加用于启动QTouch组态软件的启动图标和运行最近一次打开的工程图标

同时，Windows在开始菜单中也添加了相应的QTouch组态软件程序组，此程序组包括四项内容：QTouch启动快捷方式、QTouch开机自动启动运行、卸载QTouch组态软件及QTouch cEditor。

其中“QTouch Run”为开机自动启动运行，可将其添加到程序→启动中，开机后会自动启动QTouch跨平台组态软件并且自动运行最后一次打开的工程项目。


工程管理菜单介绍-概述

概述

2．工程管理器介绍

2.1 概述

工程管理器由菜单栏、工具栏、工作区、显示区四部分组成（如下图）。菜单栏采用的是标准的菜单形式，合理的菜单结构设计及完整的功能组合，使得用户可以使用菜单方便、快捷的组建工程；工具栏对应菜单栏中的每一项，以图标列表的形式方便用户快速操作；工作区列出了对单个工程的所有操作功能；显示区用来显示工作区中被选中的单个功能的详细信息。下面开始详细的介绍各个组成部分的功能及其使用方法。


工程文件操作

2．工程管理器介绍

2.2 工程文件操作

菜单栏中的“工程”菜单包括了对QTouch跨平台软件工程文件的各种操作命令，其中有新建工程，文件的存盘，工程的打开、工程的关闭、工程的保存、最近打开的文件列表、退出等操作命令。下表中列出了“工程”菜单的各种操作命令。

菜单名 | 图标 | 对应快捷键 | 功能说明
新建工程 |  | Ctrl + N | 新建一个工程文件，新建前应关闭当前打开的工程
打开工程 |  | Ctrl + O | 先关闭已经打开的工程，再打开指定的工程文件
关闭工程 |  | Ctrl + C | 关闭当前工程
保存工程 |  | Ctrl + S | 把当前工程存盘
最近文件列表 |  | 无 | 显示最近打开的文件列表
退出系统 |  | Ctrl + Q | 退出QTouch嵌入式组态系统


新建工程

2．工程管理器介绍

2.2 工程文件操作

2.2.1新建工程

点击“工程”菜单下的“新建工程” 或点击工具栏“新建”按钮或键入快捷键Ctrl+N。 执行此命名，弹出如下所示的工程设置对话框：

1.工程名称：在“工程名称”输入框中输入工程名称，如Project，这个名称将在工作区中显示出来，所有的文件都归属于这个工程之下，并生成以此命名的.pro工程管理器文件,即Project.pro。

2.工程描述：在“工程描述”输入框中输入对工程的描述，以便了解工程。

3.工程路径：选择工程保存的路径，此路径必须包括具体的文件夹，如：D:/工程，可在新建工程前先在本地磁盘建一个文件夹，在保存工程文件的时候，文件将会保存在这个文件夹下。

4.产品型号：选择一个产品型号，这个型号和硬件型号相一致。设备型号默认为IPC1024*768，下拉框中列出了一些设备型号如：IPC1024*768、IPC800*600、IPC800*480等。

5.本站站号：输入本站号，在多机通讯中时需要设置，多台机在一个系统中，分别以0、1、2…..等来设置。

6.启动画面：输入启动画面名称，在进行模拟或运行时，此画面将作为首页启动显示。

7.本站地址：设置本站ip地址，这个ip地址须与嵌入式设备ip地址一致，在工程下载和上传对话框中会显示此ip地址，此地址也是其它远程pc访问嵌入式设备的标识。

8.工程加密：为了保证工程的安全性，可以勾选此处的工程加密单选框，这样新建的工程就会被加密，默认的密码为“888888”，下次打开工程时候需要输入工程密码才能打开，用户下次打开工程的时候可以设置自己的工程密码。如果用户已经新建好一个工程，在新建的时候没有对工程加密，可以在“系统设置”中双击“运行系统”，勾选“工程加密”单选框也可以完成对工程的加密。


打开工程

2．工程管理器介绍

2.2 工程文件操作

2.2.2打开工程

打开一个已经建好的工程文件，执行打开操作命令后，如果该工程为加密工程，会弹出如下图所示的工程密码输入对话框：

如果没有修改工程密码，工程密码默认为“888888”，输入工程密码，点击“确定”打开工程，修改工程密码，可点击“修改”按钮弹出如下图所示的密码修改对话框：

在对话框中输入原密码、新密码、确认密码，点击“确定”完成新密码的设定。
如果打开的工程没有加密或正确输入了加密密码，系统将弹出如下图所示的“打开文件”对话框：

在文件列表框中选定要打开的文件，或在“文件名（N）”编辑框中直接输入要打开的工程文件名称（含工作目录，如：C:\ QTouch\demo640_480\ demo_project.pro），然后按“打开”按钮，就可以打开指定的工程。如果按“取消”按钮，将取消本次打开工程的操作。


关闭工程

2．工程管理器介绍

2.2 工程文件操作

2.2.3关闭工程

关闭一个QTouch中已经打开的工程文件。

点击“工程”菜单下的“关闭”或点击工具栏的 [image] 按钮或键入快捷键Ctrl+C。

执行此命令，关闭当前工程，选择关闭当前工程后，QTouch将把当前工程文件保存到硬盘上，并退回到没有打开工程文件的状态下。


保存工程

2．工程管理器介绍

2.2 工程文件操作

2.2.4保存工程

保存QTouch打开的工程文件。

点击“工程”菜单下的“保存” 或点击工具栏的 [image] 按钮或键入快捷键Ctrl+S。

执行此命令，系统自动将暂存于内存中的信息存盘，以防止由于断电或Windows系统的不稳定时，正在组态的工程文件被毁坏。


最近文件列表

2．工程管理器介绍

2.2 工程文件操作

2.2.5最近文件列表

用于快速打开上次编辑的工程文件,以提高工作效率。

点击“工程”菜单下的“最近打开的文档“右侧的工程路径。

最近打开的文件列表用于快速打开上次编辑的工程文件，以提高工作效率。执行此命令，系统会打开最近工作的工程文件，这些项是根据使用情况变化的，单击某个文档用户可以快速的打开最近编辑过的工程文件。


退出系统

2．工程管理器介绍

2.2 工程文件操作

2.2.6退出系统

退出QTouch工程管理器窗口。

点击“工程”菜单下的“退出” 或点击工具栏的 [image] 按钮或键入快捷键Ctrl+Q。

执行命令用于结束QTouch嵌入式系统的运行，与该系统窗口右上方的“关闭” 按钮及系统菜单中的退出命令功能相同。为确保安全，在退出组态环境前，及时保存所作的工作。


查看菜单

查看操作

2．工程管理器介绍

2.3 查看操作

“查看”菜单是一个下拉式菜单，包含了用于显示/隐藏工程管理器的所有工具操作。

菜单栏的“查看”菜单中列出了的各种查看操作命令，如下表所示：

菜单名 | 图标 | 对应快捷键 | 功能说明
工具栏 |  | Ctrl + N | 显示和隐藏工具栏
状态栏 |  | Ctrl + O | 显示和隐藏状态栏
工作区 |  | Ctrl + C | 显示和隐藏工作区
显示区 |  | Ctrl + S | 显示和隐藏显示区
大图标 |  | 无 | 放大显示区的操作图标
小图标 |  | Ctrl + Q | 缩小显示区的操作图标
详细信息 |  | Ctrl + Q | 查看单项操作详细信息
编辑 |  | Ctrl + Q | 编辑单项操作详细信息


详细信息

2．工程管理器介绍

2.3 查看操作

2.3.1详细信息

详细信息以表格的形式详细显示工作区中单项操作的详细信息。当我们打开一个工程，点击工作区的“数据库_开关量”,例如这个工程有很多的开关量，当执行详细信息命令时，工作区会列出开关量属性的详细信息。


编辑

2．工程管理器介绍

2.3 查看操作

2.3.2编辑

将处于以表格显示状态的详细信息变成用户可编辑状态，以方便对单条数据进行修改。

执行编辑命令，以列表显示的详细信息会变成可编辑状态，如下图所示：

单击要修改的单元格，可以对该单元格数据进行修改，可使用工具栏上的数据操作工具，对数据进行增加、追加、行拷、列拷等操作，详细操作方法见下面2.5节数据操作的介绍，修改好之后回车或移除鼠标焦点确认修改。


工具菜单

工具操作

2．工程管理器介绍

2.4 工具操作

“工具”菜单是对整个工程文件的操作，其包括工程离线模拟、工程在线模拟、下载工程和上传工程等。

菜单栏的“工具”菜单列出了各种工具操作命令，如下表所示：

菜单名 | 图标 | 对应快捷键 | 功能说明
模拟 |  | F5 | 工程主画面离线模拟
运行 |  | F6 | 工程主画面在线模拟
下载 |  | F9 | 下载工程到本地硬盘
上传 |  | F10 | 上传本地工程
U盘 |  | F11 | 生成工程文件到U盘


离线模拟

模拟

2．工程管理器介绍

2.4 工具操作

2.4.1模拟

对已经组合好的图形画面进行离线模拟测试，用于图形元素在没有与实时数据相关联之前测试组态画面的美观性和实用性。

当我们打开一个已经组态完成的工程后，执行此命令，程序就打开主画面，离线模拟，这时画面上的所有图形元素没有与实时数据相关联，整个画面为静态画面，如下图所示：


在线模拟

运行

2．工程管理器介绍

2.4 工具操作

2.4.2运行

对已经组合好的图形画面进行在线模拟测试，此时部分图形元素与实时数据相关联。

当我们打开一个已经完成的工程后，在运行系统中设置其设备型号为PC，执行此命令，程序就打开主画面，在线模拟，此时画面上的部分元素与实时数据库相关联了，数据可以实时更新，图形可以变成动画。

此时工程在PC上运行，实时数据从本地驱动中获取，也可在系统处于运行状态打开实时数据库，点击连接，弹出连接窗口，点击“连接本地”，显示连接成功，完成实时数据库的连接，此时点击模拟量或开关量可以实时监视系统中模拟量和开关量的逻辑值和采样原值。

如果工程已经在HMI上运行了，要监视HMI上的实时数据，可打开实时数据库，点击连接，弹出连接窗口，在连接ip地址处输入HMI的地址，点击“连接”按钮，显示连接成功，完成对远程HMI实时数据库的连接，此时点击模拟量或开关量可以实时监视系统中模拟量和开关量的逻辑值和采样原值，本地可实现与远程HMI数据共享。


下载工程

2．工程管理器介绍

2.4 工具操作

2.4.3下载工程

为了方便用户组态工程，可在windows系统平台下组态，组好的工程可以跨平台运行，可以通过网线或USB下载到运行设备中。

下载对话框中的三个选择框用于选择更新主程序，更新启动画面，更新控件库。

通过网线下载工程，在下载前先确定本机地址是否与运行设备的地址相匹配，可在系统参数的运行系统中更改本站地址，确定匹配后，点击下载，弹出下载对话框，如下图所示：

对话框中的目标地址192.168.1.15为新建工程时设置的本站地址，再次确定与嵌入式下位机设备地址匹配后，点击“确定”开始工程的下载，也可先ping下目标设备的地址是否连通后再下载，具体方法是，在XP系统下，点击“开始”，“运行”，输入“cmd”，回车，即可打开windows下的命令行窗口，在命令行窗口中输入“ping 192.168.1.15”，回车，可查看目标设备是否与本机连通。


上传工程

上传

2．工程管理器介绍

2.4 工具操作

2.4.4上传

将嵌入式系统中的工程文件全部上传到要进行二次组态的计算机中，执行此命令，工作区弹出上传工程窗口如下图所示，在上传地址输入框输入pc的ip地址，工程密码默认为6个8，浏览选择保存在计算机上的目录，要确保此目录下的文件夹在PC机上已存在，不存在则需先新建此文件夹，点击确定开始上传嵌入式系统中的所有的工程文件，上传进度条中显示上传文件的进度，上传完成后提示上传成功提示信息。


上传工程

U盘

2．工程管理器介绍

2.4 工具操作

2.4.4 U盘

在windows系统平台上组态好的工程可以跨平台在下位机上运行，通过网线或USB下载到运行设备中，通过USB下载或更新工程，需将组态好的文件打包到U盘，同时也可以更新最新的下位机程序和数据库，拷贝工程文件、程序或数据库到U盘的方法如下：

点击“U盘”图标，会弹出如下图所示的对话框：

单击“选择”按钮，选择u盘根目录，点击“打包工程文件到u盘”，就会将打开的工程的文件打包成名字为ctfiles的文件，如下图为打包好的工程文件已经拷贝到u盘根目录下：

点击“拷贝更新程序到u盘”，会将更新程序拷贝到u盘，如下图u盘目录中新增加的文件为下位机需更新的程序：

点击“拷贝数据库到u盘”可将数据库文件拷贝到u盘，如下图为拷贝数据库文件：

需更新的文件已经拷贝到u盘，就可以更新HMI的程序了，将u盘插入HMI的usb口，依次点击屏的左上角、右上角、左下角，弹出系统参数设置对话框，如下图所示：

在对话框中点击“工程更新”、“数据库导入”、“软件更新”按钮，点击“重启”按钮，HMI重新启动，便会运行新的工程、程序和数据库了，这样便完成了更新。


数据操作菜单

数据操作

2．工程管理介绍

2.5 数据操作

数据操作的功能是对数据库配置中的数据进行编辑，如增加、修改、删除等操作。

菜单栏的“数据操作”菜单列出了各种数据操作命令，如下表所示：

菜单名 | 图标 | 对应快捷键 | 功能说明
增加 |  | Alt + A | 在多条数据行间增加一行数据记录
追加 |  | Alt + S | 追加一行数据记录
行拷 |  | Alt + R | 复制选中行数据
列拷 |  | Alt + C | 复制一列数据
删除 |  | Alt + D | 复制选中列数据
递增 |  | Alt + I | 数据行序号递增


增加

2．工程管理器介绍

2.5 数据操作

2.5.1增加

按照选定的格式增加一行数据记录。

执行此命令，数据行将增加一个新的数据对象，且新对象的序号是在选择对象序号基础上索引生成的，新增加的一行的序号和选中行的序号相同，在选中行之上增加。

点击工具栏的“增加”工具或右键菜单“增加”或键入快捷键Alt+A，数据行会按默认数据格式在选中行数据后增加一新行数据，其序号是在选中行序号基础上加1索引生成的。


追加

2．工程管理器介绍

2.5 数据操作

2.5.2追加

按默认的数据格式追加一行数据记录。

执行此命令，数据行会在最后一行追加一个新的数据对象，且新对象的序号是在最大序号基础上索引生成的。

如选中序号为6的数据行，点击工具栏的“追加”工具或右键菜单“追加”或键入快捷键Alt+S，数据行会按默认数据格式在最后一行数据后增加一新行数据，其序号是在最大序号6的基础上加1索引生成。


行拷

2．工程管理器介绍

2.5 数据操作

2.5.3行拷

复制选中行数据，可以对一行数据进行行拷，也可以对多行数据进行行拷，执行该命令将生成一个或多个与选中行数据相同的数据行，且新对象的序号是在最大序号基础上加1索引生成的。

先选中多行数据，执行行拷命令后，新增几条数据和选择数据行数据相同，只是序号是在最大序号的基础上加1索引生成。


列拷

2．工程管理器介绍

2.5 数据操作

2.5.4列拷

以鼠标焦点列为拷贝值，拷贝当前选择列的数据。选择多行的一列数据，以鼠标所在焦点的一列数据为拷贝值，其它列的值均改变为拷贝值。在选择数据时，需从下到上选择。

先选择多行的一列数据，点击“数据操作”菜单的“列拷”或点击工具栏的列拷图标或键入快捷键Alt+C，将选中的同列中的其他数据更改成拷贝值，拷贝值为选中列中最上一列的值。


删除

2．工程管理器介绍

2.5 数据操作

2.5.5删除

删除选中行。选中要删除的数据行，点击“数据操作”菜单的“删除”或点击工具栏的删除图标或键入快捷键Alt+D，执行该操作可删除选中的数据行。


递增

2．工程管理器介绍

2.5 数据操作

2.5.6递增

选中行的序号以选中行的第一行序号为基数，按增长量递增得到每行新的序号。如下图为选择行，基数为选中行第一行的序号，点击“数据操作”菜单的“递增”或点击工具栏的递增图标或键入快捷键Alt+I，显示区弹出如下所示的设置递增量的对话框：

设置递增量，如上图，递增量设为为1，因基数是3，选择的列(第一列除外)的序号就会在3的基础上，按递增量为1，依次递增。点击确定后，新的序号列便生成了。


帮助菜单

2．工程管理器介绍

2.6 帮助菜单

“帮助”菜单中为用户提供了查阅QTouch系统内部的用户手册和在线式的帮助信息以及软件使用的有关操作命令。

菜单名 | 图标 | 对应快捷键 | 功能说明
帮助 |  | F1 | 显示系统帮助信息
关于 |  | F2 | 显示系统版本信息


帮助

2．工程管理器介绍

2.6 帮助菜单

2.6.1帮助

通俗易懂的帮助文档和在线帮助信息使用户能更快速的掌握QTouch的使用。

点击“帮助”菜单的“帮助”或键入快捷键F1。

此命令用于浏览QTouch系统软件内部的用户手册和在线式的帮助信息。执行此命令后，弹出QTouch系统软件帮助文档，如下图所示,此帮助文档将引导用户逐步深入了解QTouch系统软件，以快速掌握对QTouch系统软件的使用方法。


关于

2．工程管理器介绍

2.6 帮助菜单

2.6.2关于

介绍QTouch当前的版本，并详细列出了对上一个版本改进的地方。

点击“帮助”菜单的“关于”或键入快捷键F2。

此命令用于显示QTouch系统软件的版本信息，使客户能了解各版本的差异，以选择自己最合适的版本和及时下载最新版本。


工程管理

系统参数

2．工程管理器介绍

2.7 系统参数

系统参数的设置包括设置当前工程的运行参数，对组网进行设置和设置系统的使用用户，以及对用户进行授权。

单击“系统参数”图标，右侧的显示区会显示“运行系统”、“组网设置”、“用户权限”五个图标，如下图：

2.7.1 运行系统

2.7.2 组网设置

2.7.3 数据库设置

2.7.4 用户权限

2.7.5 MQ设置

2.7.6 页面设置


参数设置

运行系统

2．工程管理器介绍

2.7 系统参数

2.7.1 运行系统

如果当前没有打开一个工程，无法执行这三个命令，如果现在已经有一个工程正在运行，双击“运行系统”图标，显示区会弹出系统运行的参数对话框,与新建工程对话框相同， 该弹出窗口显示了正在运行的工程的名称、工程的描述信息、工程在本机的存放地址，还有该工程适用的设备型号、本站号、工程启动的画面名称和本站ip地址；各运行参数具体含义请参考新建工程时的讲述，如果要修改该工程的运行参数，可以直接在此修改，修改完毕后，点击“确认”以保存设置。


设备

组网设置

2．工程管理器介绍

2.7 系统参数

2.7.2 组网设置

组网设置是用在两台HMI进行组网监视同一条总线上的设备信息的场景下，其目的是防止HMI与设备连接出现故障，从而间断了实时数据的采集。采用双机进行组网，在主链路出现故障时，可以迅速启动备用链路，可不间断的实现实时数据的采集。如果没有此需要，在新建工程时可以不用对组网进行设置。如需要进行双机热备，我们就需要对其进行设置，如下图所示为双机热备模拟图：

正常情况下主链路启动，实现与设备的通讯，采集设备的数据，显示在主机HMI上，从机通过网线与主机相连，通过心跳探测主链路是否通讯正常，如果主链路通讯异常不能实现通讯，则从链路启动，从机变主机，从链路变为主链路，之前的主机从现在的主机处取数据并与其同步，从而实现了双机热备。

双击“组网设置”，显示区会弹出如下图所示的组网设置对话框，显示当前工程的组网设置。

采用双机热备则勾选“双机热备”单选框，在本站模式下，选择本站为主站，还是从站，如果选择的是主站，则输入从站ip地址，如果选择的是从站，则输入主站的ip地址， 心跳探测间隔为从机监测主机是否通讯正常的时间间隔，数据库同步时间为从机从主机处获得数据同步的时间间隔。


参数设置

数据库设置

2．工程管理器介绍

2.7 系统参数

2.7.3 数据库设置

双击数据库设置，显示区会弹出如下图所示的对话框：

数据库告警：数据以M(兆)为单位计算存储，当超过给定的值时就会报警。

是否自动删除数据：如果勾选此选项系统就会周期删除数据库数据。

数据保留：指定数据保留的天数。

是否使用扩展SD卡：如果勾选此选项就可以使用扩展的SD卡来存储数据库数据。

存盘周期：指数据库以指定的时间间隔存盘。

指令周期：数据库以指定的时间周期发送请求的指令。

选择专用数据库：如果勾选此选项就可以选择专用的数据库类型。

IP地址：连接到数据库的IP地址。

用户：连接到数据库的用户名。

密码：连接到数据库的密码

数据库名：连接到数据库的数据库名。

端口：连接到数据库的端口。


数据库

用户权限

2．工程管理器介绍

2.7 系统参数

2.7.4 用户权限

在工程处于打开的状态，双击“用户权限”，显示区会弹出如下图所示的对话框：

单击“添加用户”用于新建一个操作用户，这个用户是指对运行系统可操作的用户，在新增的一行表格中双击每个单元格依次输入序号、姓名、密码、权限和备注，其中权限分为0~9级，最高级为9，最低为0，输入好后点击“确认”，一个新的用户便新建成功。

如果要修改某个用户的信息，鼠标点击该用户的所在行，如要修改密码，则双击该用户密码这一列，让其变成可编辑状态，然后对其进行修改，修改完成后保存即可。

用户权限体现在整个系统中，如设置某个按钮的权限值为8，则只有当登录用户的权限值大于等于8该按钮则可以触发使用。


画面

MQ设置

2．工程管理器介绍

2.7 系统参数

2.7.5 MQ设置

在工程处于打开的状态，双击“用户权限”，显示区会弹出如下图所示的对话框：

在配置设置中有SmartQ和ActiveMQ两个单选项，其代表两个不同的服务器，但其基本属性配置相同，如以下属性：
1.服务器IP地址：输入选择的服务器的ip地址，与服务器建立连接。
2.服务器端口：匹配服务器端口。
3.服务器接收目录：数据存放在服务器中的目录，默认目录为topic。
4.客户端用户名：客户端传输的用户的登录名，用于识别。
5.传输质量：数据传输质量可选择0、1、2。
6.数据保留标识：数据保留标识选择0、1。
7.接收数据延时：设置服务器端接收数据延时时间。
选择数据分组选项卡，其用来配置客户端发送给服务器端的数据配置，如下图所示：

点击“增加按钮”添加数据条目，在每一条的“读取类型”下拉列表框选择要发送到服务器的数据类型，“起始地址”表示选中的数据类型的数据变量在组态工程中数据库中的存放的起始地址，“读取个数”表示读取选中的数据类型的数据的连续个数。


逻辑编程

2．工程管理器介绍

2.8 工程管理

2.8.6 逻辑编程

单击“逻辑编程”，右侧显示区会显示出一个“梯形图”的图标，双击该图标，弹出软逻辑编程的串口，可进行软逻辑编程。


驱动监视

2．工程管理器介绍

2.8 工程管理

2.8.7 驱动监视

单击“驱动监视”，右侧显示区会显示出一个“驱动监视”的图标，双击此图标，弹出驱动监视窗口，可以选择十六进制或十进制显示数据，清空显示，另存为等。


画面

页面设置

2．工程管理器介绍

2.7 系统参数

2.7.6 页面设置

在页面的基本设置可以设置是否画面拉伸，是否最快启动方式，页眉，页脚

的选着等。

在报警颜色设置可以对不同级别的报警设置报警时提示的颜色.


绘制系统菜单介绍-概述

概述

3．绘制系统介绍

3.1 概述

画面组态是QTouch软件中最主要的组成部分之一。除了标准的人机界面功能之外，QTouch还拥有许多特色功能，这些功能把它与其它普通的人机界面软件区别开来。

画面组态支持直线、箭头线、矩形、圆角矩形、椭圆、图像、折线、多边形、贝塞尔曲线、扇形、组合图元、超级组合等，普通的图元可以通过无穷组合成复杂的图元，图元又可以组合成超级组合形成动画等；支持普通按钮、3D按钮、数字输入框、列表框、管道、棒条、实时表格、报警列表等多种控件。

画面绘制系统图形编辑工具简单易用。QTouch绘制系统不仅能画出精彩的图形画面，而且功能强大：所有的图形元件都拥有实时选项，可以实时条件下改变其属性、尺寸和在屏幕上的位置。目前基本所有图形支持矢量控件，未来将实现所有图形支持OpenGL技术。

QTouch绘图系统由以下几部分构成：菜单栏、工具栏、图库窗口、属性窗口、编辑区，如下图所示：


文件菜单

画面文件操作

3．绘制系统介绍

3.2 画面文件操作

画面文件操作包括了对QTouch工程画面的各种操作命令，其中有新建图形，打开图形，保存、另存图形，将绘制的图形存成图片，打印等操作命令，还包括了最近文件列表操作命令以显示最近打开的绘制图形的路径。

下表中列出了“文件”菜单的各种操作命令。

菜单名 | 图标 | 对应快捷键 | 功能说明
新建图形 |  | Ctrl + N | 新建并打开一个新的绘图窗口
打开 |  | Ctrl + O | 打开指定的图形
保存 |  | Ctrl + S | 保存当前所绘制的图形
另存 |  | Ctrl + A | 另存当前绘制的图形
存成图片 |  | Ctrl + B | 把当前绘制的图形保存成图片
打印 |  | Ctrl + P | 打印当前窗口中的图形
最近文件列表 |  | 无 | 最近打开的图形列表
退出 |  | Ctrl + Q | 退出图形绘制系统窗口


新建图形

3．绘制系统介绍

3.2 画面文件操作

3.2.1 新建图形

在编辑区，新建一个空白的图形绘制窗口。

点击“文件”菜单下的“新建图形”或点击工具栏中的新建图形图标或键入快捷键Ctrl+N。

执行此命令，绘制系统会在编辑区新建一个空白图形绘制窗口，用于绘制一个新的图形。


打开

3．绘制系统介绍

3.2 画面文件操作

3.2.2 打开

打开一个已经绘制好的图形窗口。

点击“文件”菜单下的“打开”或点击工具栏中的打开图标或直接键入快捷键Ctrl+O。

执行此命令，QTouch绘制系统将弹出如下图所示的“打开文件”对话框：

在文件列表框中选定要打开的文件，或在“File name”编辑框中直接输入要打开的文件画面的名称，然后按“Open”按钮，就可以打开指定的文件画面，该画面显示在编辑区。如果按“取消”按钮，将取消本次打开文件的操作。


保存

3．绘制系统介绍

3.2 画面文件操作

3.2.3 保存

保存当前编辑区域中已经绘制好的图形。

点击“文件”菜单下的“保存”或点击工具栏中的保存图标或键入快捷键Ctrl+S。

执行此命令，如当前已绘制好的图形没保存，则弹出保存对话框，选择保存在硬盘的路径，点击确定保存该图形画面，如之前已经保存，则将更新后的图形保存到第一次保存的路径下。


另存

3．绘制系统介绍

3.2 画面文件操作

3.2.4 另存

重新保存当前编辑区域中的图形。

点击“文件”菜单下的“另存”。

执行此命令，对当前窗口的绘制图形存盘，对话框内输入新的文件名，原图形文件仍然存在。此时，只在新文件中保留修改后的内容，原图形文件不受影响。

如果当前绘制的图形是新建的图形，推荐您使用此命令，以便为新创建的绘制图形起一个有意义的名字，以便于记忆。


存成图片

3．绘制系统介绍

3.2 画面文件操作

3.2.5 存成图片

将当前编辑区域中的图形，存储成图片。

点击“文件”菜单下的“存成图片”。

执行此命令，在弹出的对话框中选择保存的路径，将当前窗口中绘制的图形保存为图片。


打印

存成图片

3．绘制系统介绍

3.2 画面文件操作

3.2.6 打印

打印当前编辑区中的绘制图形。

点击“文件”菜单下的“打印”或点击工具栏中的打印图标或键入快捷键Ctrl+P。

执行此命令，打印当前窗口中绘制的图形。


最近打开的文档

3．绘制系统介绍

3.2 画面文件操作

3.2.7 最近打开的文档

用于快速打开最近编辑的绘制图形。

点击“文件”菜单下的“最近打开的文档“右侧的文档路径。

执行此命令，系统会打开最近工作的图形文件，这些项是根据使用情况变化的，最后一次使用的在最上排列，单击某个文档路径用户可以快速的打开最近编辑过的图形文件。


退出

3．绘制系统介绍

3.2 画面文件操作

3.2.8 退出

退出图形绘制系统。

点击“文件”菜单下的“退出”或点击工具栏中的退出图标或键入快捷键Ctrl+Q。

执行此命令，结束绘制系统窗口在QTouch系统上的运行。与绘制系统窗口右上方的“关闭”按钮的功能相同。为确保安全，在绘制系统环境前，及时保存所作的工作。


编辑菜单

编辑操作

3．绘制系统介绍

3.3 编辑操作

编辑操作指在绘制图形时，可以对多个图元进行全选，对单个或多个图元进行拷贝、剪切、粘贴等操作，以方便、快捷的编辑出用户理想的图形画面。其中编辑菜单以下拉列表的形式列出了编辑操作、工具栏也以图标列表的形式列出了编辑操作的图标。

下图是“编辑”菜单列出的操作，包含了用于编辑绘制图形的一些通用性的操作：

菜单名

图标

对应快捷键

 功能说明
全选

Ctrl + A

选择图形绘制窗口中的所有图形
拷贝

Ctrl + C

复制图形绘制窗口中选择的图形

剪切

Ctrl + X

剪切图形绘制窗口中选择的图形

粘贴

Ctrl + V

把剪贴板内的图形粘贴到指定地方


全选

3．绘制系统介绍

3.3 编辑操作

3.3.1 全选

选择当前编辑区中的所有图元。

菜单操作： | 编辑 | 全选
工 具 条： |
快 捷 键： | Ctrl + A

执行此命令用于选择绘图编辑窗口中的所有的图形。


拷贝

3．绘制系统介绍

3.3 编辑操作

3.3.2 拷贝

复制选中对象到剪贴板上。

菜单操作： | 编辑 | 拷贝
工 具 条： |
快 捷 键： | Ctrl + C

执行此命令把当前选中的对象复制到剪贴板中，当前选中对象仍然存在。


剪切

拷贝

3．绘制系统介绍

3.3 编辑操作

3.3.3 剪切

剪切当前选择的对象到剪贴板。

菜单操作： | 编辑 | 剪切
工 具 条： |
快 捷 键： | Ctrl + X

执行此命令把当前选中的对象移到剪贴板中，该处选中的对象被删除。“剪切”命令和“拷贝”、“粘贴”命令一起，组成了剪贴板操作命令集。


粘贴

3．绘制系统介绍

3.3 编辑操作

3.3.4 粘贴

将剪贴板上的对象复制到当前窗口中。

菜单操作： | 编辑 | 粘贴
工 具 条： |
快 捷 键： | Ctrl + V

执行此命令用于把剪贴板中的对象复制到当前窗口中，剪贴板中的对象在粘贴后仍然存在，可供再次粘贴。


视图查看菜单

视图查看

3．绘制系统介绍

3.4 视图查看

视图查看中的各种命令用于以不同的显示方式来查看绘制窗口中的图形，达到直观的视觉效果。各种菜单命令及其功能见下表：

菜单名

图标

对应快捷键

 功能说明

设计

Ctrl + D

 切换到设计视图

恢复显示

Ctrl + R

恢复绘制区域图形的原始大小

放大

Ctrl + +

放大绘制区域中的图形

缩小

Ctrl + -

缩小绘制区域中的图形


设计

3．绘制系统介绍

3.4 视图查看

3.4.1 设计

将绘制区域中显示的图形切换到设计视图。

菜单操作： | 视图 | 设计
工 具 条： |
快 捷 键： | Ctrl + D

执行该命令将绘制区域中显示的图形切换到设计视图。


全屏

3．绘制系统介绍

3.4 视图查看

3.4.2 全屏

全屏显示绘制区域的图形。

菜单操作： | 视图 | 全屏
工 具 条： |
快 捷 键： | Ctrl + F

执行此命令全屏显示绘制区域中的图形。


恢复显示

3．绘制系统介绍

3.4 视图查看

3.4.3 恢复显示

恢复绘制区域图形的原始大小。

菜单操作： | 视图 | 恢复显示
工 具 条： |
快 捷 键： | Ctrl + R

执行此命令将恢复绘制区域图形的原始大小,对放大和缩小的绘制区域的图形进行复原操作。


放大

3．绘制系统介绍

3.4 视图查看

3.4.4 放大

放大绘制区域中的图形。

菜单操作： | 视图 | 放大
工 具 条： |
快 捷 键： | Ctrl + +

此命令将放大绘制区域中的图形,以便绘制的图形能清晰的显示。


缩小

3．绘制系统介绍

3.4 视图查看

3.4.5 缩小

缩小绘制区域中的图形。

菜单操作： | 视图 | 缩小
工 具 条： |
快 捷 键： | Ctrl + —

执行此命令将缩小绘制区域中的图形,以便能在有限的面积内显示所有绘制的图形。


边框线

3．绘制系统介绍

3.4 视图查看

3.4.6 边框线

显示/隐藏绘制区域中的边框线。

菜单操作： | 视图 | 边框线
工 具 条： |
快 捷 键： | Ctrl + W

执行此命令将显示/隐藏绘制区域中的边框线，所有的图元都在此边框线内。


绘制工具

3．绘制系统介绍

3.5 绘制工具

绘制工具菜单主要是对创建图形对象所提供的一些基本图元和超级图元。下表详细介绍了各种绘制工具。

工具名 | 图标 | 功能说明
选择工具 |  | 用于选择一个或多个当前活动图形文档中的图形对象
矩形工具 |  | 用于在当前活动图形文档绘制一个或多个矩形
直线 |  | 用于在当前活动图形文档绘制一条或多条直线
箭头 |  | 用于在当前活动图形文档绘制一条或多条带箭头的直线
椭圆 |  | 用于在当前活动图形文档绘制一个或多个椭圆
圆角矩形 |  | 用于在当前活动图形文档绘制一个或多个圆角矩形
折线 |  | 用于在当前活动图形文档绘制一条或多条折线
多边形 |  | 用于在当前活动图形文档绘制一条或多条多边形。其于折线的区别在于，多边形是封闭的，可以内部填充颜色，而折线不是封闭的
贝赛尔曲线 |  | 用于在当前活动图形文档绘制一条或多条贝塞尔曲线，贝塞尔曲线也不能内部填充
扇形 |  | 用于在当前活动图形文档绘制一个或多个扇形
组合动画 |  | 用于在当前活动图形文档内用其他的图元绘制出的图形加入到该超级组对象中组成的动画对象
控件名 | 图标 | 功能说明
普通按钮 |  | 用于在当前活动图形文档绘制一个或多个按钮
3D按钮 |  | 用于在当前活动图形文档绘制一个或多个具有3D效果的按钮图形对象
数字编辑框 |  | 用于在当前活动图形文档绘制一个或多个数字编辑框
下拉列表框 |  | 用于在当前活动图形文档绘制一个或多个具有下拉效果的列表框
3D管道 |  | 用于在当前活动图形文档绘制一个或多个具有3D效果的管道图形对象
棒条 |  | 用于在当前活动图形文档绘制一个或多个棒条
报表 |  | 用于在当前活动图形文档绘制一个或多个报表
实时表格 |  | 在当前图形文档中创建一个表格来显示若干个实时量的报表对象
事件信息 |  | 在当前图形文档中创建一个listview控件，用于在运行时显示报警历史数据
控件名 | 图标 | 功能说明
透明时钟 |  | 用于在当前活动图形文档绘制一个或多个透明时钟
方形时钟 |  | 用于在当前活动图形文档绘制一个或多个方形时钟
历史曲线 |  | 用于向用户显示历史存盘数据的数据变化趋势
实时曲线 |  | 用于向用户显示实时模拟量的变化趋势
实时表计 |  | 用于显示模拟量所处的范围
垂直滑杆 |  | 方便用户向目标配置文件发送设置的值
水平滑杆 |  | 方便用户向目标配置文件发送设置的值


选择工具

3．绘制系统介绍

3.5 绘制工具

3.5.1 选择工具

选择当前活动图形文档中一个或多个图形对象。

在基本图形窗口点击“选择工具”或点击“绘制工具”菜单下的选择工具图形。

执行此命令，将鼠标移动到编辑区，按住鼠标左键，滑动鼠标，选择好区域后，松开鼠标左键，鼠标经过的矩形区域中的图元便被选中。


矩形工具

3．绘制系统介绍

3.5 绘制工具

3.5.1 矩形工具

矩形工具是绘制系统中很基本的也是很重要的绘制工具，可以完成很多工业上的应用，比如矩形工具可以实时关联开关量或模拟量，可以让关联的量以文本或填充色方式刷新显示，关联量后可以根据量的变化水平移动、垂直移动、倾斜移动、显示或隐藏，可以用颜色、背景图片填充或做边框模拟工业现场中的场景，也可以执行脚本程序，在绘制系统中画好一个矩形后，选中矩形，可通过其属性X坐标、Y坐标设置该矩形在图形绘制窗口的位置，通过属性高度、宽度设置其大小，通过属性Z层设置其显示的层次。矩形工具的属性描述如下：
1.显示：选择“是”则在图形绘制窗口显示，选择“否”则隐藏。
2.实时关联：关联一个系统变量，显示变量的值。
3.脚本属性：新建一个脚本函数，点击矩形触发执行事件。
4.线属性：更改矩形的边框线的颜色、线宽、线形。
5.填充属性：选择矩形内部填充的颜色；选择填充的类型包括实背景填充、网格填充、横线、斜线等等填充方式；可选择填充的图形是否透明。
6.文本属性：在文本属性中输入矩形上显示的文字；可在文本水平或垂直对齐属性中设置文本在矩形中显示的位置；同时也可文本的颜色和文本的字体。
7.图象属性：在此矩形中添加png图片，制作出图像图元。
下几幅图为通过矩形工具绘制的效果：


直线

3．绘制系统介绍

3.5 绘制工具

3.5.3 直线

在当前活动图形文档绘制一条或多条直线。

在基本图形窗口点击“直线”或点击“绘制工具”菜单下的直线。

执行此命令，将鼠标移动到编辑区，按住鼠标左键，并任意拖动到合适的位置，松开鼠标左键，就绘制出与X轴，Y轴成任意角度的直线。如果想再继续绘制直线的话，同上一步操作；绘制水平直线和垂直直线的方法：按住Ctrl键的同时，分别以水平方向和垂直方向拖动直线，将分别得到水平直线和垂直直线。如果想结束直线的绘制，那么在编辑区内任意地方点击鼠标右键，就完成了矩形的绘制，并通过直线的属性按需求进行设置。


箭头

3．绘制系统介绍

3.5 绘制工具

3.5.4 箭头

在基本图形窗口点击“箭头”或点击“绘制工具”菜单下的箭头工具。将鼠标移动到编辑区，按住鼠标左键，滑动鼠标到一定的位置，就画出了一个箭头，选中箭头，可通过其属性X坐标、Y坐标设置该箭头在图形绘制窗口的位置。箭头还具有一些其它的属性：
1.箭头形态：可改线的颜色、箭头的颜色、线宽、线形，线形包括：无线、实线、虚线、点线、点虚线、点点虚线；箭头包括左箭头和右箭头，左右箭头可分别现在箭头类型和设置箭头的大小。如下图为几种不同形态的箭头：

2.旋转角度：在工具栏中有左旋转和右旋转操作，在旋转角度属性设置一次旋转的角度，可控制一次旋转的幅度。
3.旋转中心编号：此编号用来确定箭头在左右旋转时的中心位置。


椭圆

3．绘制系统介绍

3.5 绘制工具

3.5.5 椭圆

在当前活动图形文档绘制一个或多个椭圆。

在基本图形窗口点击“椭圆”或点击“绘制工具”菜单下的椭圆。

执行此命令，将鼠标移动到编辑区，按住鼠标左键，并任意拖动到合适的位置，松开鼠标左键，就完成了一个椭圆的绘制。如果想再继续绘制椭圆的话，同上一步操作；如果想结束椭圆的绘制，那么在编辑区内任意地方点击鼠标右键，就完成了对椭圆的绘制，并通过椭圆的属性按需求进行设置。


圆角矩形

3．绘制系统介绍

3.5 绘制工具

3.5.6 圆角矩形

在当前活动图形文档绘制一个或多个圆角矩形。

在基本图形窗口点击“圆角矩形”或点击“绘制工具”菜单下的圆角矩形。

执行此命令，将鼠标移动到编辑区，按住鼠标左键，并任意拖动到合适的位置，松开鼠标左键，就完成了一个圆角矩形的绘制。如果想再继续绘制圆角矩形的话，同上一步操作；如果想结束圆角矩形的绘制，那么在编辑区内任意地方点击鼠标右键，就完成了对圆角矩形的绘制，并通过圆角矩形的属性按需求进行设置，其中可以“圆角大小”属性改变其矩形圆角的大小。


折线

3．绘制系统介绍

3.5 绘制工具

3.5.7 折线

在当前活动图形文档绘制一个或多个折线。

在基本图形窗口点击“折线”或点击“绘制工具”菜单下的折线。

执行此命令，将鼠标移动到编辑区，在编辑区内单击鼠标左键确定折线的起始点，然后松开鼠标左键，移动至折线的第二个点的位置，单击左键确定第二点，重复此过程直到最后一点，最后在编辑区内任意位置单击鼠标右键确定折线的绘制完成。如果想再继续绘制折线的话，同上一步操作；如果想结束折线的绘制，那么在编辑区内任意地方点击鼠标右键，就完成了对折线的绘制，并通过折线的属性按需求进行设置。


多边形

3．绘制系统介绍

3.5 绘制工具

3.5.8 多边形

在当前活动图形文档绘制一个或多个多边形。

在基本图形窗口点击“多边形”或点击“绘制工具”菜单下的多边形。

执行此命令，将鼠标移动到编辑区，在编辑区内单击鼠标左键确定多边形的起始点，然后松开鼠标左键，移动至多边形的第二个点的位置，单击左键确定第二点，重复此过程直到最后一点，最后在编辑区内任意位置单击鼠标右键确定多边形的绘制完成。如果想再继续绘制多边形的话，同上一步操作；如果想结束多边形的绘制，那么在编辑区内任意地方点击鼠标右键，就完成了对多边形的绘制，并通过多边形的属性按需求进行设置。


贝赛尔曲线

3．绘制系统介绍

3.5 绘制工具

3.5.2 贝赛尔曲线

贝塞尔曲线是依据四个位置任意的点坐标绘制出的一条光滑的曲线，绘制好一个贝塞尔曲线后，移动贝塞尔曲线中间的两个控制点的位置，可以改变曲线的弯曲程度，整个曲线会在起点和终点锁定的情况下均匀的移动，完成各种圆滑曲线的绘制。绘制好的贝塞尔曲线还可以沿着设置好的旋转中心进行一定角度的旋转。如下图为绘制的工业中的发电机运转过程中风轮的状态图：

贝塞尔曲线具有的属性说明如下：

1.旋转角度：对绘制好的贝塞尔曲线，可通过改变它的旋转角度，让其沿中心点旋转，以达到满意的效果。
2.操作角度：操作角度用于设置图元一次旋转的角度，在工具栏中点击左旋转和右旋转操作时，图元可以按此角度进行旋转。
3. 旋转中心编号：此编号用来确定贝塞尔曲线在向左或向右旋转时的中心位置。 其中直线、箭头、折线也可以围绕旋转中心左旋转和右旋转，图元图标如下：


扇形

3．绘制系统介绍

3.5 绘制工具

3.5.10 扇形

在当前活动图形文档绘制一个或多个扇形。

在基本图形窗口点击“扇形”或点击“绘制工具”菜单下的扇形。

执行此命令，将鼠标移动到编辑区，按住鼠标左键，并任意拖动到合适的位置，松开鼠标左键，就完成了一个扇形的绘制。如果想再继续绘制扇形的话，同上一步操作；如果想结束扇形的绘制，那么在编辑区内任意地方点击鼠标右键，就完成了对扇形的绘制，并通过扇形的属性按需求进行设置。


超级组对象

3．绘制系统介绍

3.5 绘制工具

3.5.3 超级组对象

组合动画是将不同的图像图元组合在一起，经过变位闪烁、动画显示或根据实时关联的值的改变来形成动画效果。

变位闪烁指组合的动画关联某个变量，该变量的值只要发生改变，组合动画就发生动画的切换闪烁；动画闪烁是与关联的变量的值的变化没有关系，只要运行了画面，该组合动画就会按顺序的切换图像图元闪烁形成动画；组合动画还可以根据实时关联的值显示动画，组合动画的“组属性”窗口中的序号为动画中的每个图像图元显示的标记，关联的值为某个图像图元对应的序号的值时显示该图像图元。

通过超级组合对象可以组合成单组循环动画，也可组合成多组嵌套循环动画，下面先描述单组循环动画的组合方式：
先新建多个图形，图形大小、形状可自选，如我们先在界面上画1个矩形，将矩形的属性中的线形属性改为无线，透明属性改为是，然后选择此矩形，复制粘贴2次，一起形成3个矩形，单击选择每个矩形在其图像属性中点击浏览分别选择我们已经通过Photoshop或其他图形编辑工具已编辑好的图像，如下图左边为已经操作完成的3副图形：

然后在基本图元中单击超级组对象，在图形绘制窗口绘制一个超级组合对象，可在其属性中更改其文本、位置、大小等属性，如更改名称为“组合动画2”，上右图所示。选中上左3副图形中的每副图形，在其“加入组”属性的下拉框中选择组合动画2，这样3副图像都加入了组合动画2中。选中“组合动画2”，在其“组属性”属性中点击浏览，会弹出如下图所示的编辑对话框：

如上图，编辑对话框中列出了我们刚加入的3副图像，此时“组合动画2”如果运行的话就会按0到2的顺序依次变换，可以选中要调整顺序的图像的序号通过“上移”和“下移”按钮对单个图像的显示顺序进行调整，也可通过“删除”按钮删除选择的图像，或重新加入新的图像。可为所有的图像命名以示区别，选中单个图像，在修改文本编辑框中输入描述性的文本,编辑好后点击“确定”按钮完成对“组合动画2”的编辑。编辑好的“组合动画2”可以实时关联一个模拟量，当模拟量的值为0、1、2的时候可以对应显示单副画面，可在“组合动画2”的“实时关联”属性中设置关联的模拟量。
下面描述多个组合动画嵌套显示的组合动画的新建方法，先新建第一个组合动画，图形大小、形状可自选，如下图为已经新建好的两个图形：

将左边的两个图像分别加入“组合动画1”中，将“组合动画1”关联一个模拟量，如“组合动画1”关联模拟量序号为0的模拟量。再新建一个组合动画2，如下图：

将右边的一个图像加入“组合动画2”中，并将上面组合好的“组合动画1”也加入到“组合动画2”，将“组合动画2”关联一个模拟量，如“组合动画2”关联模拟量序号为1的模拟量。这样点击“组合动画2”，在其“组属性”属性中点击浏览，会弹出如下图所示的编辑对话框：

同样可以调整两幅组合动画的顺序，如要对两个组合动画进行重新编辑的话，可选择要编辑的组合动画，点击“移除”按钮，移除组合动画从新编辑，编辑好的新的动画可再次加入到“组合动画2”中。之前我们已经对2副组合动画进行了模拟量的实时关联，将此动画运行在已经新建好的组态工程项目中，如果模拟量序号为1的量的值为0的时候，“组合动画1”显示，同时如果模拟量序号为0的量此时的值为0在“组合动画1”中序号为0的图像显示，同理根据模拟量序号为0、1的值“组合动画3”会显示出对应的图形。已经组合好的动画可以用工具栏的“下一副”或“滚动显示”来查看组合效果。 以上为最简单的多个组合动画嵌套显示的组合方法，可根据实际项目的需要，组合出更为复杂的嵌套型的组合动画。


普通按钮

3．绘制系统介绍

3.5 绘制工具

3.5.12 普通按钮

在当前活动图形文档绘制一个或多个普通按钮。

在基本控件窗口点击“普通按钮”或点击“绘制工具”菜单下的普通按钮。

执行此命令，将鼠标移动到编辑区，按住鼠标左键，并任意拖动到合适的位置，松开鼠标左键，就完成了一个普通按钮的绘制。如果想再继续绘制普通按钮的话，同上一步操作；如果想结束普通按钮的绘制，那么在编辑区内任意地方点击鼠标右键，就完成了对普通按钮的绘制，并通过普通按钮的属性按需求进行设置。如在按钮的属性框里选择“文本”更改显示在按钮上的文本，选择“激活”为True，那么按钮即为运行状态，在“脚本属性”选项里可以为按钮添加需要脚本。


3D按钮

3．绘制系统介绍

3.5 绘制工具

3.5.4 3D按钮

3D按钮的主要功能是执行脚本函数、下发控制命令，3D按钮有两种模式，一种是普通按钮，一种是切换按钮，普通按钮是点下按钮下发命令后，按钮弹起，切换按钮是点下按钮后按钮处于沉入状态，再次点击，按钮弹起。
3D按钮是以两幅3D效果的图作为按钮的背景图，可以通过属性框中的“按下图像”和“弹起图像”来丰富3D按钮，以达到最好的画面表达效果。选中3D按钮，可通过其属性X坐标、Y坐标设置该矩形在图形绘制窗口的位置，通过属性高度、宽度设置其大小，通过属性Z层设置其显示的层次。3D按钮还具有一些其它的属性：
1.实时关联：关联系统中的变量，可根据变量的值对3D按钮进行水平移动、垂直移动、倾斜移动等。
2.脚本属性：新建一个脚本函数，点击矩形触发执行事件，可在脚本属性弹出对话框的“权利指数”输入框输入权利指数值，如果系统登录的用户的权利值小于在此设置的值，则该3D按钮显示为灰色，即处于禁用状态，不允许该用户进行操作。
3.激活：如激活属性为否，则该3D按钮处于禁用状态，为是则处于可用状态。
4.文本：在文本属性中输入矩形上显示的文字；可在文本水平或垂直对齐属性中设置文本在矩形中显示的位置；同时也可文本的颜色和文本的字体。
5.按下图像：点击3D按钮未释放时，3D按钮显示的图像。
6.弹起图像：点击3D按钮释放后，或未点击按钮时显示的图像。
7.按钮模式：按钮模式包括“普通按钮”和“切换按钮”，如选择“普通按钮”则点击按钮释放后按钮图像由“按下图像”变成“弹起图像”，同时执行一个下发控制串命令；如选择“切换按钮”，需和脚本函数!SendConC( kc0 , kc1 )一起使用，如脚本函数设成为!SendConC( 0 , 1 )，当一次点击该按钮并释放后图像变成按下图像，同时执行控制串序号为0的命令，当再次点击该按钮并释放后按钮图像变成弹起图像，同时执行控制串序号为1的命令。


数字编辑框

3．绘制系统介绍

3.5 绘制工具

3.5.5 数字编辑框

数字编辑框在画面中是具有数字输入功能的元件，可以设定它的最大值，最小值和默认值，下送倍数一般为1倍，也可以相应的设置为10倍或100倍，以获得不同的单位进行编辑，既将输入在数字编辑框中的值放大100倍，下送到脚本及驱动程序中。
选中数字编辑框，可通过其属性X坐标、Y坐标设置该矩形在图形绘制窗口的位置，通过属性高度、宽度设置其大小。数字编辑框具有一些其它的属性：
1.最小值：在数字编辑框中输入的值如果小于此处设置的最小值，执行下发命令后，系统将以最小值下发到驱动程序中。
2.最大值：在数字编辑框中输入的值如果大于此处设置的最大值，执行下发命令后，系统将以最大值下发到驱动程序中。
3.小数点宽度：设置用户输入的值的小数点后的小数的个数。
4.默认值：在用户输入数值前界面默认显示的值。
5.下送倍数：将用户输入的值放大或缩小的倍数，将放大或缩小后的新的值下送到驱动程序中。
在下位机上触摸数字编辑框会数字输入软键盘，触摸软键盘上的数字后点击“输入”，可完成对编辑框值的设定。


下拉列表框

3．绘制系统介绍

3.5 绘制工具

3.5.6 下拉列表框

下拉列表框是将同类型的多个命令放在一起，供用户选择性的下发需要的命令，要配合按钮使用，按钮可将下拉列表选中的命令下发到控制的设备中，绘制好下拉列表框需要对列表框进行编辑，选中下拉列表框，点击其“列表框编辑”属性中的浏览，在弹出的对话框中点击“添加”按钮，双击每行的“显示文本”文本框输入显示的文本，在“命令文本”输入框中输入下发的命令的编号，下发的命令编号来自工程管理器中的数据库_输出量中的序号，如下图为工程管理器中的数据库_输出量的设置：

可根据需要点击“添加”按钮增加下拉数据的条数，设置完显示文本和命令文本后，点击“上移”“下移”调整下拉数据在下拉文本框中显示的顺序，点击“确定”完成对下拉列表框的编辑，如下图：
下拉列表框是具有选择功能的操作元件，通过在属性框里的“列表框编辑”选项，在弹出的编辑对话框中输入相应的“显示文本”和“命令文本”的值，点击“确定”按钮后，在属性框中选择“激活”选项，激活下拉列表框，运行工程项目，单击下拉列表框，就可以看到显示的效果。根据选定的下拉选项下发对应的命令到驱动程序中。

完成对下拉列表框的编辑后保存运行系统，在画面上点击设置好的下拉列表框，会出现如下图所示的效果：

当选择下拉列表框中的第二行“写单个AO”后，再点击右边与之相关联的按钮，系统就会执行“命令文本”为1的命令，该命令即为数据库_开出量中序号为1的命令，即将设备地址为1模拟量地址为1的值设成数值9。


3D管道

3．绘制系统介绍

3.5 绘制工具

3.5.7 3D管道

3D管道控件可以绘制出管道内部填充色渐变的图形，3D管道属性框中“管道模式”选择“水平”和“垂直”两种模式，让填充的颜色水平渐变或垂直渐变。3D管道具有一些其它的属性：
1.边框颜色：管道边框的颜色设置。
2.管道颜色：管道中间3D渐变的颜色设置。
3.边框宽度：设置管道边框的宽度。
4.管道模式：设置管道中间3D渐变的颜色显示方式，包括横向渐变和纵向渐变。


棒条

3．绘制系统介绍

3.5 绘制工具

3.5.8 棒条

棒条是用填充色来显示关联量的变化情况，其棒条的属性值里的“最大值”和“最小值”是代表了一个棒条所显示的实时量的最大值和最小值。它的顶部颜色代表着没有值的填充，底部颜色代表着有值的填充。其他属性：
1.边框颜色：选择棒条边框的颜色。
2.棒条颜色：选择棒条有值的填充色。
3.边框宽度：棒条边框的宽度。
4.棒条模式：棒条填充显示的方式，包括水平显示和垂直显示。
5.背景颜色：棒条未被填充的区域显示的颜色。
6.当前值：在棒条未关联值时，棒条默认显示的值。


报表

3．绘制系统介绍

3.5 绘制工具

3.5.9 报表

报表可供用户查询单个变量在历史数据库中某时间段的数据存盘记录，用于对该变量进行统计分析，当使用报表时，报表所在的画面的文档类型需设为报表，要查询某时间段的存盘数据，画面中还需要添加一个查询按钮，在按钮脚本中添加脚本函数!SaveDataQuery( )，运行画面后点击查询按钮会弹出如下图所示的时间段设定窗口：

窗口中默认起始时间为当天零晨，默认终止时间为点击查询按钮的时刻，同时也可以查询上月、本月、昨日的存盘时间。
绘制好报表后，通过报表的属性按需求进行设置。如在属性框中“计算模式”的选择。报表的其他属性：
1.线属性：有线颜色、线宽、线形的设置，线形包括实线、虚线、点线、点虚线、点点虚线。
2.填充属性：报表的背景填充颜色、填充类型和显示的文本。
3.计算模式：包括表格数据、求和、均值、最小值、最大值、日期值、按时统计。
4.绘制方式：指表格横行绘制和纵向绘制。


实时表格

3．绘制系统介绍

3.5 绘制工具

3.5.10 实时表格

“实时表格”可横向或纵向显示关联的变量，同其他绘制工具不同的是其可以以表格的形式实时关联多个采集量。选中已经绘制好的“实时表格”，点击其数据管理属性，在弹出的对话框中点击“增加”会弹出“选择管理变量”对话框，从列出的变量中选中要关联的量，重复选中“实时表格”后的操作，添加多个变量，如下左图所示，下右图为横向显示关联的变量：

选中要调整位置的变量，点击“上移”或“下移”完成对变量位置的调整，点击“确定“完成对“实时表格”的变量的关联，这时被管理的量就会以表格的形式横向或纵向的显示出来。


事件信息

3．绘制系统介绍

3.5 绘制工具

3.5.11 事件信息

事件信息控件可实时显示报警信息或事件信息，也可以查询显示历史报警信息或历史事件信息，下面以示例来分别说明事件信息的用法。
1.实时显示报警信息，如在数据库_开关量中设置10个开关量的值为1时表示为发生了告警，告警方式设为异常告警，告警级别为1，工程转换设置成ORTo(396),表示这10开关量与模拟量序号为396的量相或，只要这10个量中有一个量的值为1，模拟量序号为396的量的值便为1，同理设置另外10个数据库_开出量的值为1时表示了发生了故障，设置告警级别为2，设置工程转换为ORTo(397),其它属性设置如上图设置一样,在主画面上用两个指示灯分别表示告警、和故障显示信息，告警指示灯实时关联模拟量396，脚本属性中设为!SetAlarmLevel( 1 )、!OpenDialog( Alarm.drw, 15 , 70 , 549 , 355 )、!ClearRealAlarm()，!SetAlarmLevel( 1 )表示查询告警级别为1的异常告警量，!OpenDialog( Alarm.drw, 15 , 70 , 549 , 355 )表示弹出告警记录窗口，!ClearRealAlarm()表示清除上次实时告警显示的记录；故障指示灯实时关联模拟量397，脚本属性中设为!SetAlarmLevel( 2 )、!OpenDialog( Alarm.drw, 15 , 70 , 549 , 355 )、!ClearRealAlarm()。 画面类型为画面不为报表，“告警”按钮的脚本函数设为!SetAlarmLevel( 1 )，“故障”按钮的脚本函数设为!SetAlarmLevel( 2)，“全部”按钮脚本函数设为!SetAlarmLevel( 9)，9为告警级别，表示查看所有的报警信息，在这里包括告警和故障信息。如果上述10个告警和10个故障开关量中都存在1值的量，点击告警会出现如下图所示的告警显示信息：

点击全部会出现如下显示告警和故障的信息：

2.查询显示历史报警信息，如上例中的历史告警和故障信息也可以通过事件信息控件查询出来，要查询某时间段的告警或故障信息数据，画面中需要添加一个查询按钮，在按钮脚本中添加脚本函数!SaveDataQuery( )，画面类型应改为报表，“告警”按钮的脚本函数设为!SetAlarmLevel( 1 )，“故障”按钮的脚本函数设为!SetAlarmLevel( 2)，“全部”按钮脚本函数设为!SetAlarmLevel( 9)，“查询”按钮的脚本设为!SaveDataQuery( )，运行系统，在主画面上点击“故障日志”按钮弹出历史告警查询窗口，在弹出窗口中点击“全部”，再点击“查询”，在弹出时间选中窗口中设置要查询的时间段，点击“确定”就会显示该时间段的历史告警和故障信息。


透明时钟

3．绘制系统介绍

3.5 绘制工具

3.5.21 透明时钟

在基本控件窗口点击“透明时钟”或点击“绘制工具”菜单下的透明时钟，将鼠标移动到编辑区，按住鼠标左键，并任意拖动到合适的位置，松开鼠标左键，就完成了一个透明时钟的绘制。如下图所示为已经绘制好的一个透明时钟：

绘制好的透明时钟无需进行设置，运行组态工程后即可实时的显示系统的时间。


历史曲线

3．绘制系统介绍

3.5 绘制工具

3.5.12 历史曲线

历史曲线实现了历史数据的曲线浏览功能。运行时，历史曲线能够根据需要画出相应历史数据的趋势效果图。对于历史数据的变化有一个很好的体现和描述。如下图所示为已经绘制好的一个历史曲线：

双击历史曲线弹出如下图所示的历史曲线属性设置窗口：

如上图为历史曲线的外观设置选项卡，如可分别设置历史曲线的X轴、Y轴的主、分刻度，可设置X轴主分刻度和Y轴的值的显示范围，可在“时间显示格式”的下拉列表框中选择X轴时间的显示格式，如年-月-日、年-月、月-天、天-时。
选择“数据”选项卡，可显示历史曲线的实时关联的数据的设置窗口，如下图所示：

“显示数据条数”的下拉文本框中最多可设置显示16条数据，在“选择线条”的下拉文本框中依次选中每条线，可对应的在“数据ID”处设置该线与系统中的模拟量的关联，如要关联系统中模拟量序号为0的量则在此处输入0，可设置选中线条的线条宽度、线条颜色和类型，设置好后点击确定保存设置，运行系统后已经关联的模拟量的历史存盘数据就会在历史曲线中显示出来。


实时曲线

3．绘制系统介绍

3.5 绘制工具

3.5.13 实时曲线

实时曲线是用曲线显示一个或多个数据对象数值的动画图形，像笔绘记录仪一样实时记录数据对象值的变化情况。实时曲线用绝对时间为横轴标度，此时，实时曲线显示的是数据对象的值与时间的函数关系。如下图所示为已经绘制好的一个实时曲线：

双击实时曲线弹出如历史曲线的外观设置选项卡一样实时曲线属性设置窗口，其属性和历史曲线属性设置相同，同样点击“数据”选项卡其设置窗口也同历史曲线的“数据”设置串口类似，设置方法同理，此处从略。


实时表计

3．绘制系统介绍

3.5 绘制工具

3.5.14 实时表计

实时表计可以设置显示关联的量所处的区域范围，如下图所示为已经绘制好的一个实时表计，并关联了实时量：

双击实时表计弹出如下图所示的实时表计属性设置窗口：

如上图为实时表计的外观设置选项卡，如可分别设置表盘标签的文本和文本颜色，可设置表盘填充颜色、最大刻度量程、最小刻度量程、主刻度、分刻度，也可设置指针的颜色和实时值的字体颜色等。
选择“数据”选项卡，可显示实时表计正常区、警告区、异常区的颜色及范围，如下图所示：

注意设置的区域必须在表计的量程范围内，同时也可通过不勾选任一告警区的有效单选框，取消该区在实时表计中的显示。


垂直滑杆

3．绘制系统介绍

3.5 绘制工具

3.5.15 垂直滑杆

垂直滑杆可以滑动滑鼠，将滑鼠指示的值下发到关联的变量中，如下图所示为已经绘制好的一个垂直滑杆：

双击垂直滑杆弹出如下图所示的垂直滑杆属性配置窗口：

可在其配置窗口中设置滑杆的上刻度的最大值、最小值，可设置刻度值标签的字体颜色和当前显示值字体颜色，刻度值/当前值比值用于确定实际值，发送的目标配置文件序号即为系统中数据库_输出量的编号，表示指针移动停止后下发的开出控制命令。


水平滑杆

3．绘制系统介绍

3.5 绘制工具

3.5.26 水平滑杆

在基本控件窗口点击“水平滑杆”或点击“绘制工具”菜单下的水平滑杆，将鼠标移动到编辑区，按住鼠标左键，并任意拖动到合适的位置，松开鼠标左键，就完成了一个水平滑杆的绘制。如下图所示为已经绘制好的一个水平滑杆：

双击水平滑杆弹出如下图所示的水平滑杆属性配置窗口：

s

可在其配置窗口中设置滑杆的上刻度的最大值、最小值，可设置刻度值标签的字体颜色和当前显示值字体颜色，刻度值/当前值比值用于确定实际值，发送的目标配置文件序号即为系统中数据库_输出量的编号，表示指针移动停止后下发的开出控制命令。


图形操作

3．绘制系统介绍

3.6 图形操作

图形操作菜单命令是针对选中的一个或多个图形对象进行排列的操作,下表列出了各种对图形进行操作的命令：

工具名 | 图标 | 对应快捷键 | 功能说明
左对齐 |  | Ctrl + L | 将当前活动图形文档中两个或两个以上选中的图形对象，以基准对象左位置对齐。
右对齐 |  | Ctrl + R | 将当前活动图形文档中两个或两个以上选中的图形对象，以基准对象右位置对齐。
顶对齐 |  | Ctrl + T | 将当前活动图形文档中两个或两个以上选中的图形对象，以基准对象顶端位置对齐
底对齐 |  | Ctrl + B | 将当前活动图形文档中两个或两个以上选中的图形对象，以基准对象底端位置对齐
垂直居中对齐 |  | 无 | 将当前活动图形文档中两个或两个以上选中的图形对象，以基准对象的宽度的中心对齐
水平居中对齐 |  | 无 | 将当前活动图形文档中两个或两个以上选中的图形对象，以基准对象的高度的中心对齐
水平翻转 |  | 无 | 将当前活动图形文档中两个或两个以上选中的图形对象，以基准对象的高度的中心对齐
垂直翻转 |  | 无 | 将当前活动图形文档中两个或两个以上选中的图形对象，以基准对象的高度的中心对齐
垂直等距分布 |  | 无 | 将当前图形文档中选中的两个或两个以上图形对象以基准对象作垂直等距分布
水平等距分布 |  | 无 | 将当前图形文档中选中的两个或两个以上图形对象以基准对象作水平等距分布
等宽 |  | 无 | 将当前图形文档中选中的两个或两个以上图形对象设置成与基准对象宽度一致
等高 |  | 无 | 将当前图形文档中选中的两个或两个以上图形对象设置成与基准对象高度一致
等高宽 |  | 无 | 将当前图形文档中选中的两个或两个以上的图形对象设置成与基准对象宽度和高度一致
组合 |  | Ctrl + G | 将当前图形文档中选中的两个或两个以上的图形对象组合为一个图形对象
拆组 |  | Ctrl + B | 将当前图形文档中一个由多个图元组合好的图形对象，拆分成多个单独的图形对象
左旋转 |  | 无 | 将当前活动图形文档中图形对象，按逆时针方形旋转一个指定的角度
右旋转 |  | 无 | 将当前活动图形文档中图形对象，按顺时针方形旋转一个指定的角度
下一幅 |  | 无 | 显示由多幅画面组成的超级组合图形对象的下一幅画面
滚动显示 |  | 无 | 在图形绘制窗口，让超级组合图形对象滚动显示形成动画


左对齐

3．绘制系统介绍

3.6 图形操作

3.6.1 左对齐

两个或两个以上选中的图形对象，以基准对象左位置对齐。

选择图形对象，点击“图形操作”菜单的“左对齐”或点击工具栏左对齐图标或键入快捷键Ctrl+L。

执行此命令，将当前活动图形文档中两个或两个以上选中的图形对象，以基准对象左位置对齐。


右对齐

3．绘制系统介绍

3.6 图形操作

3.6.2 右对齐

两个或两个以上选中的图形对象，以基准对象右位置对齐。

选择图形对象，点击“图形操作”菜单的“右对齐”或点击工具栏右对齐图标或键入快捷键Ctrl+R。

执行此命令，将当前活动图形文档中两个或两个以上选中的图形对象，以基准对象右位置对齐。


顶对齐

3．绘制系统介绍

3.6 图形操作

3.6.3 顶对齐

两个或两个以上选中的图形对象，以基准对象顶位置对齐。

选择图形对象，点击“图形操作”菜单的“顶对齐”或点击工具栏顶对齐图标或键入快捷键Ctrl+T。

执行此命令，将当前活动图形文档中两个或两个以上选中的图形对象，以基准对象顶位置对齐。


底对齐

3．绘制系统介绍

3.6 图形操作

3.6.4 底对齐

两个或两个以上选中的图形对象，以基准对象底位置对齐。

选择图形对象，点击“图形操作”菜单的“底对齐”或点击工具栏底对齐图标或键入快捷键Ctrl+B。

执行此命令，将当前活动图形文档中两个或两个以上选中的图形对象，以基准对象底位置对齐。


垂直居中对齐

3．绘制系统介绍

3.6 图形操作

3.6.5 垂直居中对齐

两个或两个以上选中的图形对象，以基准对象的宽度的中心对齐。

选择图形对象，点击“图形操作”菜单的“垂直居中对齐”或点击工具栏垂直居中对齐图标。

执行此命令，将当前活动图形文档中两个或两个以上选中的图形对象，以基准对象宽度的中心对齐。


水平居中对齐

3．绘制系统介绍

3.6 图形操作

3.6.6 水平居中对齐

两个或两个以上选中的图形对象，以基准对象的高度的中心对齐。

选择图形对象，点击“图形操作”菜单的“水平居中对齐”或点击工具栏水平居中对齐图标。

执行此命令，将当前活动图形文档中两个或两个以上选中的图形对象，以基准对象宽度的中心对齐。


垂直等距分布

3．绘制系统介绍

3.6 图形操作

3.6.7 垂直等距分布

两个或两个以上选中的图形对象，以基准对象作垂直等距分布。

选择图形对象，点击“图形操作”菜单的“垂直等距分布”或点击工具栏垂直等距分布。

执行此命令，将当前活动图形文档中两个或两个以上选中的图形对象，以基准作垂直等距分布。


水平等距分布

3．绘制系统介绍

3.6 图形操作

3.6.8 水平等距分布

两个或两个以上选中的图形对象，以基准对象作水平等距分布。

选择图形对象，点击“图形操作”菜单的“水平等距分布”或点击工具栏水平等距分布。

执行此命令，将当前活动图形文档中两个或两个以上选中的图形对象，以基准作水平等距分布。


等宽

3．绘制系统介绍

3.6 图形操作

3.6.1 等宽

两个或两个以上选中的图形对象，设置成以基准对象宽度一致。

选择图形对象，点击“图形操作”菜单的“等宽”或点击工具栏等宽。

执行此命令，将当前活动图形文档中两个或两个以上选中的图形对象，以基准作水平等距分布。


等高

3．绘制系统介绍

3.6 图形操作

3.6.10 等高

两个或两个以上选中的图形对象，设置成以基准对象高度一致。

选择图形对象，点击“图形操作”菜单的“等高”或点击工具栏等高。

执行此命令，将当前活动图形文档中两个或两个以上选中的图形对象，设置成以基准对象高度一致。如下图所示，为设置前后图形：


等高宽

3．绘制系统介绍

3.6 图形操作

3.6.11 等高宽

两个或两个以上选中的图形对象，设置成以基准对象高度和宽度一致。

选择图形对象，点击“图形操作”菜单的“等高宽”或点击工具栏等高宽。

执行此命令，将当前活动图形文档中两个或两个以上选中的图形对象，设置成以基准对象高度和宽度一致。


组合

3．绘制系统介绍

3.6 图形操作

3.6.12 组合

两个或两个以上选中的图形对象，将其组合成一个整体图形。

选择图形对象，点击“图形操作”菜单的“组合”或点击工具栏组合图标。

执行此命令，将当前活动图形文档中两个或两个以上选中的图形对象，形成个整体单元。


拆组

3．绘制系统介绍

3.6 图形操作

3.6.13 拆组

一个由多个图元组合好的图形对象，将其拆出组合成多个单独的图形对象。

选择图形对象，点击“图形操作”菜单的“拆组”或点击工具栏拆组图标。

执行此命令，将当前活动图形文档中一个由多个图元组合好的图形对象，将其拆出组合成多个单独的图形对象。


逆时针

3．绘制系统介绍

3.6 图形操作

3.6.14 逆时针

将当前活动图形文档中图形对象，按逆时针方形旋转一个指定的角度。

执行此命令，将把在当前活动图形文档中选中的图形对象，按逆时针方形旋转一个指定的角度。如下图所示为旋转前后的图形：

执行此命令，将当前活动图形文档中两个或两个以上选中的图形对象，以基准作水平等距分布。


顺时针

3．绘制系统介绍

3.6 图形操作

3.6.15 顺时针

将当前活动图形文档中图形对象，按顺时针方形旋转一个指定的角度。

选择图形对象，点击“图形操作”菜单的“顺时针”或点击工具栏顺时针图标。

执行此命令，将把在当前活动图形文档中选中的图形对象，按顺时针方形旋转一个指定的角度。


下一幅

3．绘制系统介绍

3.6 图形操作

3.6.16 下一幅

显示由多幅画面组成的超级组合图形对象的下一幅画面。

选择图形对象，点击“图形操作”菜单的“水平等距分布”或点击工具栏水平等距分布。

执行此命令，将当前活动图形文档中两个或两个以上选中的图形对象，以基准作水平等距分布。


滚动显示

3．绘制系统介绍

3.6 图形操作

3.6.17 滚动显示

在图形绘制窗口，让超级组合图形对象滚动显示形成动画。

选择超级组合图形对象，点击“图形操作”菜单“滚动显示”或点击工具栏滚动显示图标。

执行此命令，被选中的超级组合图形对象便滚动起来形成了动画。


Z序操作

3．绘制系统介绍

3.7 Z序操作

Z序操作菜单命令是对重叠在一起的多个图形对象在Z轴上的显示排列操作。

菜单名 | 图标 | 功能说明
上移 |  | 将当前活动图形文档中重叠在一起的图形对象中的一个上移。
最顶端 |  | 让当前活动图形文档中重叠在一起的图形对象中的一个最顶端显示。
下移 |  | 将当前活动图形文档中重叠在一起的图形对象中的一个下移。
最底端 |  | 让当前活动图形文档中重叠在一起的图形对象中的一个最底端显示。


上移

3．绘制系统介绍

3.7 Z序操作

3.7.1 上移

上移重叠在一起的图形对象中一个。

选择重叠在一起的图形对象中一个，点击“图形操作”菜单“上移”或点击工具栏上移图标。

执行此命令，被选中的一个图形会上移一层显示。


最顶端

3．绘制系统介绍

3.7 Z序操作

3.7.2 最顶端

最顶端显示重叠在一起的图形对象中一个。

选择重叠在一起的图形对象中一个，点击“图形操作”菜单“最顶端”或点击工具栏最顶端图标。

执行此命令，被选中的一个图形会在最上一层显示。


下移

3．绘制系统介绍

3.7 Z序操作

3.7.3 下移

下移重叠在一起的图形对象中一个。

选择重叠在一起的图形对象中一个，点击“图形操作”菜单“下移”或点击工具栏下移图标。

执行此命令，被选中的一个图形会下移一层显示。


最底端

3．绘制系统介绍

3.7 Z序操作

3.7.4 最底端

最底端显示重叠在一起的图形对象中一个。

选择重叠在一起的图形对象中一个，点击“图形操作”菜单“最底端”或点击工具栏最底端图标。

执行此命令，被选中的一个图形会在最下一层显示。


字体设置

3．绘制系统介绍

3.8 字体设置

字体设置用于对当前活动图形文档中选中的字符串进行样式字体颜色设置。

菜单名 | 图标 | 对应快捷键 | 功能说明
加黑 |  | Ctrl + B | 将当前图形文档中选中的字符串的字体设置为粗体
加斜 |  | Ctrl + I | 将当前图形文档中选中的字符串的字体设置为斜体
底线 |  | Ctrl + U | 将当前图形文档中选中的字符串的字体加下划线
水平左 |  | Ctrl + L | 将当前图形文档中选中的字符串的对齐方式为居左对齐
水平中 |  | Ctrl + M | 将当前图形文档中选中的字符串的对齐方式为居中对齐
水平右 |  | Ctrl + R | 将当前图形文档中选中的字符串的对齐方式为居右对齐
垂直顶 |  | Ctrl + T | 将当前图形文档中选中的字符串的对齐方式为垂直居上
垂直中 |  | Ctrl + J | 将当前图形文档中选中的字符串的对齐方式为垂直居中
垂直底 |  | Ctrl + B | 将当前图形文档中选中的字符串的对齐方式为垂直居下
文本颜色 |  | 无 | 设置当前图形文档中字符串的颜色


图元实时关联

3．绘制系统菜单介绍

3.9 图元实时关联

在绘制系统中，组态好工业画面后，需要对部分图元进行数据实时关联，即关联模拟量、开关量、设备状态、系统变量，从而对实时数据进行监视，选中需要关联的图元，点击右侧属性编辑中的实时关联，弹出如下所示的实时关联配置窗口：

在站点号处输入本站的站号，在数据种类选择框选择要关联量的种类，点击编号文本框后的浏览按钮会弹出变量选择窗口，如下图所示：

窗口左边列出了变量的类型，点击要进行管理的变量类型，窗口右边便会列出该类型的所有的变量，如上图为左边选择了模拟量，右边列出了32个模拟量，此处的32个模拟量为我们在数据库配置中配置的模拟量，在右边模拟量出点击选择要关联的具体的模拟量，此处假设选择编号为4的模拟量，点击确定后，变量选择完成，在“关联设置“对话框的编号处就会自动生成刚选择的编号4，同时描述处会自动生成编号为4的模拟量的描述。
图元关联了量之后也可以水平移动、垂直移动、闪烁或隐藏，以水平移动为例，在实时关联对话框中，点击“水平移动”后面的浏览按钮选择关联的模拟量，选择好后，图元会根据关联的模拟量的值的增加或减少来左右移动。
刷新方式用来表示变量在界面显示方式，包括文本显示和填充色显示，如果选择以文本显示则可设置文本小数点个数，如选择以颜色填充的话，可设置0值颜色和1值颜色。


帮助菜单

图元脚本属性

3．绘制系统菜单介绍

3.10 图元脚本属性

脚本属性操作可以让用户快速的实现登陆，快速的操作存盘和报警数据，方便的设置系统的运行环境，以及获得系统状态和时间等。
脚本属性用于按钮图元上，在点击触发图元后执行。选择需要关联的按钮图元，点击其属性中的脚本属性的浏览，弹出如下图所示的脚本属性配置窗口：

点击取函数可以取出各种脚本控制函数，如存盘报警函数、设备操作函数、时间函数、图元操作函数等等，详细参考弹出的选择函数窗口：

关于各函数的含义，请参考本说明文档第九章系统函数的介绍，这里详细说明下如何快捷的取出用户想要的函数，并快速的配置好函数的各参数。


概述

4．QTouch与PLC的连接

4.1 概述

本章介绍了常见厂家的PLC和QTouch组态软件的接入，包括QTouch采取什么方式和PLC通讯、组态软件与PLC进行连接时的配置参数设置、PLC编程软件的设置和PLC与上位机PC或下位机HMI的连接接线说明等，通过本章的介绍用户可以轻松的将PLC与上位机PC或下位机HMI连接起来，从而使用QTouch组态软件实现对PLC数据的采集和设备状态的控制，进而将用户组态好的工程应用到实际项目工程中。本章也介绍了如何将一个我们还没有的驱动加入到QTouch设备驱动列表中，使用户在组态设备时直接从驱动设备列表中选择。


概述

西门子 (SIEMENS) PLC

4．QTouch与PLC的连接

4.2 西门子 (SIEMENS) PLC

SIEMENS S7/200 系列PLC与SmartFactory触摸屏或PC的连接说明

QTouch软件设置:

参数项 | 推荐设置 | 可选设置 | 注意事项
PLC类型 | SIEMENS S7/200 adapter |  |
通讯口类型 | RS485 | RS232/USB |
波特率 | 9600 | 9600/19200/38400/57600/115200 | 必须与PLC的通讯口设定相同
数据位 | 8 | 7 or 8 | 此协议数据位固定为8位
停止位 | 1 | 1 or 2 | 必须与PLC的通讯口设定相同
校验 | 偶校验 | 偶校验/奇校验/无 | 必须与PLC的通讯口设定相同
设备地址 | 0 | 0-255 | 必须与PLC的站号设定相同

可操作的地址范围:

PLC地址类型 | 可操作范围 | 格式 | 说明
Q | 0-65535 | DDDD | 外部输出节点
I | 0-65535 | DDDD | 外部输入节点
VB | 0-65535 | DDDD | 数据寄存器
VW | 0-65535 | DDDD | 数据寄存器
VD | 0-65535 | DDDD | 数据寄存器

说明:D表示十进制。

上表可操作范围为实际SmartFactory的可操作范围，实际PLC的范围会大于或小于此范围。

详细连接图:

说明：SIEMENS S7-200 系列PLC包括CPU212/CPU214/CPU215/CPU216/CPU221/CPU222/ CPU224/CPU226等型号，都可以通过CPU单元上的编程通讯口(PPI端口)连接PPI通讯适配 器与SmartFactory触摸屏连接通讯，其中CPU226有两个通讯端口，都可以用来连接触摸屏， 但需要分别设定通讯参数。通过CPU直接连接时需要注意软件中通讯参数的设定，相关详细 设定说明请参考SIEMENS公司提供的技术手册。
1.CPU单元(通讯适配器6ES7901-3CB30-0XA0)

SIEMENS S7/300 系列PLC与SmartFactory触摸屏或PC的连接说明

QTouch软件设置:

参数项 | 推荐设置 | 可选设置 | 注意事项
PLC类型 | SIEMENS S7/300 PC/HMI adapter |  |
通讯口类型 | USB总线 | RS232/USB |
波特率 | 9600 | 9600/19200/38400/57600/115200 | 必须与PLC的通讯口设定相同
数据位 | 8 | 7 or 8 | 此协议数据位固定为8位
停止位 | 1 | 1 or 2 | 必须与PLC的通讯口设定相同
校验 | 奇校验 | 偶校验/奇校验/无 | 必须与PLC的通讯口设定相同
设备地址 | 0 | 0-255 | 必须与PLC的站号设定相同

可操作的地址范围:

PLC地址类型 | 可操作范围 | 格式 | 说明
Q | 0-65535 | DDDD | 外部输出节点
I | 0-65535 | DDDD | 外部输入节点
QW | 0-65535 | DDDD | 外部输出节点
IW | 0-65535 | DDDD | 外部输入节点
DB | 0-65535 | DDDD | 数据寄存器
DW | 0-65535 | DDDD | 数据寄存器

说明:D表示十进制。

上表可操作范围为实际SmartFactory的可操作范围，实际PLC的范围会大于或小于此范围。

详细连接图:

说明：SIEMENS S7-300 系列PLC包含CPU312/CPU313/CPU314/CPU315/CPU316/ CPU318等型号，都可以通过SIEMENS提供的HMI通讯适配器或者PC适配器与 SmartFactory触摸屏连接，使用适配器时请注意DIP开关的设定，相关详细设定说明 请参考SIEMENS公司提供的技术手册。
1.HMI 通讯适配器 6ES7901-3CB30-0XA0

2.PC 通讯适配器 6ES7972-0CA23-0XA0


概述

施耐德（MODICON）PLC

4．QTouch与PLC的连接

4.3 施耐德（MODICON）PLC

MODICON Compact(A/E984)/Momentum/Quantum系列PLC与SmartFactory 触摸屏的连接说明

QTouch软件设置:

参数项 | 推荐设置 | 可选设置 | 注意事项
PLC类型 | ModbusRTU |  |
通讯口类型 | RS232 | RS232/RS485 |
波特率 | 9600 | 9600/19200/38400/57600/115200 | 必须与PLC的通讯口设定相同
数据位 | 8 | 7 or 8 | 此协议数据位固定为8位
停止位 | 1 | 1 or 2 | 必须与PLC的通讯口设定相同
校验 | 偶校验 | 偶校验/奇校验/无 | 必须与PLC的通讯口设定相同
设备地址 | 0 | 0-255 | 必须与PLC的站号设定相同

可操作的地址范围:

PLC地址类型 | 可操作范围 | 格式 | 说明
1X | 0-65535 | DDDD | 系统内部/外部输出节点
2X | 0-65535 | DDDD | 系统内部/外部输入节点
3X | 0-65535 | DDDD | 模拟量输出寄存器
4X | 0-65535 | DDDD | 模拟量输入寄存器

说明:D表示十进制。

上表可操作范围为实际SmartFactory的可操作范围，实际PLC的范围会大于或小于此范围。

详细连接图:

说明：Modicon Compact/Momentum/Quantum系列的PLC都可以通过CPU模块上的通讯端口采用ModbusRTU协议与HMI或PC连接，其中Compact(A/E 984)系列中的171 CCS 960 XX没有modbus串行通讯端口，不能直接连接，但可以通过通讯模块171 JNN 210 32来连接，相关详细设定请参照考施耐德电气公司提供的技术手册。
1.CPU单元(Compact/Momentum系列PLC RS232通讯)

说明：Compact系列的CPU E984-258/265/275/285的两个Modbus串行通讯口和Momentun系列CPU171 CCS700/760/780的通讯口1都是RJ-45的硬件接口，接线图如上图，需要注意相关的硬件设定，请参考施耐德提供的技术手册。

2.CPU单元(Momentum系列PLC RS485通讯)

说明：只有Momentum系列的CPU171 CCS 780和171 CCC 980拥有RS485 Modbus串行通讯口接线图如上图，需要注意的相关的软硬件设定，请参考施耐德提供的技术手册。
3.CPU单元(Compact/Quantum系列PLC RS232通讯)

说明：Compact系列的CPU A984和E984-241/245/251/255的Modbus串行通讯口和Quantum系列140CPU系列的Modbus通讯口都是9针的RS232硬件接口，其中Compact的A984-131/141、E984-241/251和Quantum的140CPU 434/534有两个Modbus通讯口，接线图如上图，需要注意相关的软硬件设定，请参考施耐德提供的技术手册。
4.通讯模块(172 JNN 210 32 使用于 Momentum系列)

说明：172 JNN 210 32适配器与CPU 171 CCS 780 或者 171CCC 780 配置时，适配器上的RS485端口无效，请注意相关的硬件设定，请参考施耐德提供的技术手册。
5.通讯模块(NOM 21X 00用于 Quantum系列 PLC RS232通讯)


概述

4.4 欧姆龙(OMRON)PLC

4．QTouch与PLC的连接

4.4 欧姆龙(OMRON)PLC

OMRON CPM 系列 PLC 与 SmartFactory触摸屏连接说明

QTouch软件设置:

参数项 | 推荐设置 | 可选设置 | 注意事项
PLC类型 | CMP1A | CJ/CV/CMP/CP (485 2W) | OMRON (485 2W)仅在采用 RS485两线式连接时选用
通讯口类型 | RS232 | RS232/RS485 |
波特率 | 9600 | 9600/19200/38400/57600/115200 | 必须与PLC的通讯口设定相同
数据位 | 7 | 7 or 8 | 必须与PLC的通讯口设定相同
停止位 | 2 | 1 or 2 | 必须与PLC的通讯口设定相同
校验 | 偶校验 | 偶校验/奇校验/无 | 必须与PLC的通讯口设定相同
设备地址 | 0 | 0-255 | 必须与PLC的站号设定相同

可操作的地址范围:

PLC地址类型 | 可操作范围 | 格式 | 说明
RR8 | 0-65535 | DDDD | 单通道8点继电器
RR12 | 0-65535 | DDDD | 单通道12点继电器
RR16 | 0-65535 | DDDD | 单通道16点继电器
RD | 0-65535 | DDDD | 数据寄存器DM区

说明:D表示十进制。

上表可操作范围为实际SmartFactory的可操作范围，实际PLC的范围会大于或小于此范围。

详细连接图:

说明：OMRON CPM系列的PLC包含CPM1/CPM1A/CPM2A三个系列，其中CPM1/CPM1A系列的CPU上无标准串行通信口，必须配置OMRON CPM1-CIF01(RS232)通讯适配器或者OMRON CPM1-CIF11(RS422)通讯适配器，才能利用Host-Links 与触摸屏连接。CPM2A的CPU单元则带有RS232串行通讯口，可直接连接触摸屏，也可以配置CPM1-CIF01(RS232)通讯适配器或者OMRON CPM1-CIF11(RS422)通讯适配器来连接。相关硬件说明请参考OMRON公司提供的手册。
1.CPU单元

2.通讯模块 CPM1-CIF01

说明:应将CPM1-CIF01 适配器的模式设定开关设置在HOST LINK通信模式
3.通讯模块 CPM1-CIF11


概述

三菱(Mitsubishi) PLC

4．QTouch与PLC的连接

4.5 三菱(Mitsubishi) PLC

MITSUBISHI FX 系列 PLC 与 SmartFactory触摸屏连接说明

QTouch软件设置:

参数项 | 推荐设置 | 可选设置 | 注意事项
PLC类型 | FX2n | FX2n/FX/FX0n/FX2c/FX2n | 采用不同的PLC时，应选择对应的PLC类型
通讯口类型 | RS485 | RS232/RS485 |
波特率 | 9600 | 9600/19200/38400/57600/115200 | 必须与PLC的通讯口设定相同
数据位 | 7 | 7 or 8 | 必须与PLC的通讯口设定相同
停止位 | 1 | 1 or 2 | 必须与PLC的通讯口设定相同
校验 | 偶校验 | 偶校验/奇校验/无 | 必须与PLC的通讯口设定相同
设备地址 | 0 | 0-255 | 必须与PLC的站号设定相同

可操作的地址范围:

PLC地址类型 | 可操作范围 | 格式 | 说明
X | 0-65535 | DDDD | 1点为单位读取外部输入节点
XW | 0-65535 | DDDD | 16点为单位读取外部输入节点
Y | 0-65535 | DDDD | 1点为单位读取外部输出节点
YW | 0-65535 | DDDD | 16点为单位读取外部输出节点
M | 0-65535 | DDDD | 1点为单位读取外部辅助节点
MW | 0-65535 | DDDD | 16点为单位读取外部辅助节点
DW | 0-65535 | DDDD | 数数据寄存器

说明:D表示十进制。

上表可操作范围为实际SmartFactory的可操作范围，实际PLC的范围会大于或小于此范围。

详细连接图:

说明：MITSUBISHI FX 系列PLC 包含FX0/FX0s/FX0n/FX1s/FX1n/FX2nc/FX2n等型号，都可以通过CPU 单元上的编程通讯口与触摸屏连接，也可以通过通讯接口板232BD或者485BD来连接，使用BD模块通讯事，PLC类型应当选择MITSUBISHI FX0n/FX2/FX2n ,并需要注意通讯格式寄存器D8120的设定，应将BFM#0的b9与b8设置为0。相关详细硬件说明请参考MITSUBISHI公司提供的技术手册。
1.CPU单元

2.通讯模块RS232BD

3.通讯模块RS485BD


概述

5．设备选择

5.1 概述

本章介绍了串口设备、网络设备和总线设备的概念和作用，详细说明设备配置的方法和步骤。当新建一个工程，要实现对工业过程的实时监控，就必须使系统与外部硬件设备相连接，使系统能够从外部设备读取数据并控制外部设备的工作状态，因此设备的选择和配置极其重要。


配置串口设备

5．设备选择

5.2 配置串口设备

在组态过程中，要实现和支持串口协议的设备进行通讯，我们就需新建串口设备，在工作区域点击“串口设备”，在显示区会出现“新建串口设备”图标和名为“GenDate”的设备图标，“GenDate”是在没有连接串口设备的情况下，用来模拟的设备。双击“新建串口设备”图标,会弹出如图所示的串口设备对话框，其中包括设备的基本属性、端口的配置和数据分组的格式设置。

5.2.1 基本属性

5.2.2 端口配置


基本属性

5．设备选择

5.2 配置串口设备

5.2.1 基本属性

选择设备名称，在此处选择该新建的工程所用的设备，点击选择弹出设备选择窗口，如下图所示：

设备选择窗口列表框中列出了系统目前支持的所有设备的驱动，为了在众多的设备驱动中方便快速的找到所需要的设备驱动，系统对所有的设备驱动采用了一定的分类方法排列，分类方法如下图所示：

这样用户就可以根据分类方法快速找到适合自己的设备驱动程序。

选择好设备后，在内存编号输入框输入设备驱动的内存编号，该编号用于实时数据库索引该设备驱动的内存数据。

选择通讯协议，当我们选择好驱动设备后，该设备支持的协议就会在协议列表中列出来如图所示：

该图中显示的DCON协议为我们选择了泓格公司的IO模块I8000后列出的协议，表示I8000支持的协议为DCON协议。

选择冗余配置，选择主链路或备用链路，在没有进行双击热备的情况下选择主链路，在进行双击热备并且做为从站的情况下选择备用链路，备用链路通常情况下不启动，在检查到主链路发生异常时，自动启动。

输入设备数据发送间隔时间，此时间表示向驱动中发生两条查询串之间的时间间隔。

如果要禁用此设备，在系统运行是不启动改设备的驱动的话，勾选“禁用设备”单选框。

确认对新建设备的基本属性设置是否完成，点击“检查”按钮，提示操作信息，如果弹出”设置正确”，则完成了对基本属性的设置，如果对基本设置还有不太清楚的地方，点击“帮助”，参考帮助文档，加深理解。


端口配置

5．设备选择

5.2 配置串口设备

5.2.2 端口配置

新建串口设备，当我们设置好设备的基本属性后，我们需对设备的端口进行配置，配置串口如下图所示：

1.串口号：选择设备串口号，此处下拉框列出了COM0~COM30,共31个串口号，根据设备来选择串口号。

2.波特率：输入串口波特率，输入串口设备单位时间内传输码元符号的个数即波特率，常使用的波特率为9600。

3.数据位：选择串口设备的数据位，数据位是用来衡量通信中实际数据位的参数，标准的值是5、6、7和8位。如何设置取决于你想传送的信息。比如，标准的ASCII码是0～127（7位）。扩展的ASCII码是0～255（8位）。如果数据使用简单的文本（标准 ASCII码），那么每个数据包使用7位数据。

4.停止位：选择串口设备的的停止位，停止位用来表示单个包的最后一位。典型的值为0、1、1.5和2位。

5.校验位：选择串口设备的校验位,校验位是串口通信中一种简单的检错方式。下拉框中提供了五种检错方式：无校验、奇校验、偶校验、固定1校验、固定0校验。

6.超时：输入超时时间，即此串口设备在此时间内未完成一次数据的发送则停止发送数据。


发送串

数据分组

5．设备选择

5.2 配置串口设备

5.2.3 数据分组

根据设备在总线中的位置、设备的功能型号等信息来进行数据分组，数据分组窗口如下：

点击“增加”按钮，弹出如下图所示的发送串添加窗口：

1.设备名称：在设备名称文本框输入设备的名称。

2.设备地址：设备的地址为，该设备在总线中的地址，在设备地址中设置设备在总线中的地址号。

3.数据区：在数据区中设置要读取的数据所在的区域，如DO、DI、AO、AI。

4.寄存器地址：寄存器地址为要读取的设备内数据区的起始地址。

5.连续个数：连续的个数为要读取寄存器的数据个数。

6.内存数据类型：在“内存数据类型”下拉框中选择放入共享内存的区域，即AI区或DI区。

7.起始地址：在“起始地址”处设置从设备读取出来的数据存放在实时共享内存中的起始位置。

8.连续的个数：在“个数“处设置在共享内存中要储存数据的个数。 设置完成后点击确定，就会在”串口设备“输入框中多出一条相同格式的发送串，点击“检查”，如果弹出“设置正确”对话框，则完成了对发送串的设置。


配置网络设备

5．设备选择

5.3 配置网络设备

新建网络设备，在工作区域点击“网络设备”，在显示区会出现“新建网络设备”图标，双击“新建网络设备”图标,会弹出网络设备对话框，其中包括设备的基本属性、端口的配置和发送串的格式设置。其中基本属性设置的不同在于在设备列表中只列出了有网络通讯的设备的驱动，其数据分组方法与新建串口设备时的基本属性设置和数据分组方法相同，这里从略。

5.3.1 端口配置


基本属性

5．设备选择

5.3 配置网络设备

5.3.1 基本属性

选择设备名称，在此处选择该新建的工程所用的设备，点击选择弹出设备选择窗口，如下图所示：

设备选择窗口列表框中列出了系统目前支持的所有设备，为了在众多的设备驱动中方便快速的找到所需要的设备驱动，系统对所有的设备驱动采用了一定的分类方法排列，分类方法如下图所示：

这样用户就可以根据分类方法快速找到适合自己的设备驱动程序。

选择好设备后，在内存编号输入框输入设备驱动的内存编号，该编号用于实时数据库索引该设备驱动的内存数据。

选择通讯协议，当我们选择好驱动设备后，该设备支持的协议就会在协议列表中列出来如图所示：

该图中显示的DCON协议为我们选择中了泓格公司的IO模块I8000后列出的协议，说明I8000支持的协议为DCON协议。

选择冗余配置，选择主链路或备用链路，通常情况下选择主链路。

输入设备数据发送间隔时间，即循环周期。

如果要禁用此设备，勾选“禁用设备”单选框。

确认对新建设备的基本属性设置是否完成，点击“检查”按钮，提示操作信息，如果弹出”设置正确”，则完成了对基本属性的设置，如果对基本设置还有不太清楚的地方，点击“帮助”，参考帮助文档，加深理解。


端口配置

5．设备选择

5.3 配置网络设备

5.3.1 端口配置

在组态过程中，要实现同支持以太网协议的设备进行通讯，需新建网络设备，我们需对设备的端口进行配置，如下图为其端口配置窗口：

1.ip地址：在“ip地址”输入框输入设备的ip地址。

2.端口：在“端口“输入框输入设备的端口号。

3.ip地址1：在采用双网路的环境下，设置从站的ip地址；如果没有采用双机热备此处可不设置，默认为0。

4.端口1：在采用双击热备的环境下，设置从站的端口号；如果没有采用双机热备则此处可不设置，让其默认为0；

设置完成后，点击”检查“，如果弹出”设置正确“，则完成了端口的配置。


发送串

数据分组

5．设备选择

5.3 配置网络设备

5.3.3 数据分组

根据设备在总线中的位置、设备的功能信号等信息来进行数据分组，数据分组窗口如下：

点击“增加”按钮，弹出如下图所示的发送串添加窗口：

在设备名称文本框输入设备的名称；在设备地址中设置设备在总线中的地址号；在数据区中设置要读取的数据所在的区域，如I、AI、M；在“寄存器地址”设置设备数据的起始位数；在“连续个数”处设置要读取设备中数据的个数；在“内存数据类型”下拉框中选择数据类型，如AI、DI；在“起始地址”处设置从设备读取出来的数据存放在实时共享内存中的起始位置；在“个数“处设置在共享内存中要储存数据的个数。设置完成后点击确定，就会在”串口设备“输入框中多出一条相同格式的发送串，点击“检查”，如果弹出“设置正确”对话框，则完成了对发送串的设置。


配置总线设备

5．设备选择

5.4 配置总线设备

在组态过程中，要实现同支持总线的设备进行通讯，需新建总线设备，在工作区域点击“总线设备”，在显示区会出现“新建总线设备”图标，双击“新建总线设备”图标,会弹出总线设备对话框，其中包括设备的基本属性、端口的配置和发送串的格式设置。其中基本属性设置的不同在于在设备列表中只列出了有总线通讯设备的驱动，其数据分组方法与新建串口设备时的基本属性设置和数据分组方法相同，这里从略。

5.4.1 端口配置


基本属性

5．设备选择

5.4 配置总线设备

5.4.1 基本属性

选择设备名称，在此处选择该新建的工程所用的设备，点击选择弹出设备选择窗口，如下图所示：

设备选择窗口列表框中列出了系统目前支持的所有设备，为了在众多的设备驱动中方便快速的找到所需要的设备驱动，系统对所有的设备驱动采用了一定的分类方法排列，分类方法如下图所示：

这样用户就可以根据分类方法快速找到适合自己的设备驱动程序。

选择好设备后，在内存编号输入框输入设备驱动的内存编号，该编号用于实时数据库索引该设备驱动的内存数据。

选择通讯协议，当我们选择好驱动设备后，该设备支持的协议就会在协议列表中列出来如图所示：

该图中显示的CANBus协议为我们选择中了泓格公司的PCBased设备的CANBus。

选择冗余配置，选择主链路或备用链路，通常情况下选择主链路。

输入设备数据发送间隔时间，即循环周期。

如果要禁用此设备，勾选“禁用设备”单选框。

确认对新建设备的基本属性设置是否完成，点击“检查”按钮，提示操作信息，如果弹出”设置正确”，则完成了对基本属性的设置，如果对基本设置还有不太清楚的地方，点击“帮助”，参考帮助文档，加深理解。


端口配置

5．设备选择

5.4 配置总线设备

5.4.1 端口配置

新建总线设备，当我们设置好设备的基本属性后，我们需对设备的端口进行配置，配置串口如下图所示：

1.设备地址：在“设备地址”输入框输入总线设备的地址。

2.端口：在“端口“输入框输入设备的端口号。

3.速度：在“速度”输入文本框输入总线设备的传输速度。

设置完成后，点击”检查“，如果弹出”设置正确“，则完成了端口的配置。


发送串

数据分组

5．设备选择

5.4 配置总线设备

5.4.3 数据分组

根据设备在总线中的位置、设备的功能信号等信息来进行数据分组，数据分组窗口如下：

点击“添加”按钮，弹出如下图所示的发送串添加窗口：

在设备名称文本框输入设备的名称；在设备地址中设置设备在总线中的地址号；在数据区中设置要读取的数据所在的区域，如I、AI、M；在“寄存器地址”设置设备数据的起始位数；在“连续个数”处设置要读取设备中数据的个数；在“内存数据类型”下拉框中选择数据类型，如AI、DI；在“起始地址”处设置从设备读取出来的数据存放在实时共享内存中的起始位置；在“个数“处设置在共享内存中要储存数据的个数。设置完成后点击确定，就会在”串口设备“输入框中多出一条相同格式的发送串，点击“检查”，如果弹出“设置正确”对话框，则完成了对发送串的设置。


配置总线设备

配置OPC设备

5．设备选择

5.5 配置OPC设备

在组态过程中，要实现同支持OPC的设备进行通讯，需新建OPC设备，在工作区域点击“OPC设备”，在显示区会出现“新建OPC设备”图标，双击“新建OPC设备”图标,会弹出OPC设备对话框，其中包括设备的基本属性、端口的配置和发送串的格式设置。其中基本属性设置的不同在于在设备列表中只列出了有OPC通讯设备的驱动，其数据分组方法与新建串口设备时的基本属性设置和数据分组方法相同，这里从略。

5.5.1 端口配置


端口配置

5．设备选择

5.5 配置总线设备

5.5.1 端口配置

新建OPC设备，当我们设置好设备的基本属性后，我们需对设备的端口进行配置，配置串口如下图所示：

1.OPC服务器：在“ocp服务器”输入框输入服务器的地址。

2.读取组对象：输入读取组对象。

3.写入组对象：输入写入组对象。

4.读取对象：输入读取对象。

5.写入对象：输入写入对象。

设置完成后，点击”检查“，如果弹出”设置正确“，则完成了端口的配置。


概述

6．数据库配置

6.1 概述

数据库配置中包设备变量，中间变量，系统变量。

设备变量，关联设备类型的变量（如：IO设备等）
中间变量，---------------------------------
系统变量，系统内部的变量（如：系统时间等） 。


实时数据库

设备变量

6．数据库配置

6.2 设备变量

QTouch支持的通讯设备很多，这里用IO设备变量建立来说明。如下：

a)在设备变量选择IO变量，在软件的工作区点击鼠标右键在弹出的对话框中选择新建或者在工具栏上单击新建就可以来创建IO设备变量。弹出

对话框如下：

b）在基本设置栏的参数有：

数据类型：提供的类型有模拟量和数字量

连续个数：需要创建IO变量的个数

变量名：IO设备关联的变量名

描述：对变量的注释和说明

单位：变量的单位（一般指模拟量的单位，数字量单位可以为空）

c）IO连接属性栏的参数有：

设备名：是创建设备的名称（图中是以松下PLC设备为例）

设备地址：IO设备的地址

寄存器区：IO设备的寄存器区（如松下plc的寄存器区有X,Y,R,等）

寄存器地址：IO设备的寄存器地址。

数据类型：提供的数据类型很多，Bit位开关量，char8位有符号数等）

读写类型：只读，只写，和读写

最大值/最小值: IO设备变量的最大值和最小值

初值：IO设备的初始值

变比：对IO设备的值变比（变比为1，则变量值不变等值；变比为2，则变量值为其2倍）

d）存盘属性栏参数有：

存盘方式：

1）变位存盘,--------------------------------------------------

2）周期存盘,周期时间一到就存盘数据

3）整点存盘----------------------------------------------------

存盘时间：存盘的周期时间

e）在报警属性栏中选择告警的方式和告警属性.


历史数据库

中间变量

6．数据库配置

6.3 中间变量

a)在设备变量选择IO变量，在软件的工作区点击鼠标右键在弹出的对话框中选择新建或者在工具栏上单击新建就可以来创建IO设备变量。弹出

对话框如下：

b）在基本设置栏的参数有：

数据类型：提供的类型有模拟量和数字量

连续个数：需要创建IO变量的个数

变量名：IO设备关联的变量名

描述：对变量的注释和说明

单位：变量的单位（一般指模拟量的单位，数字量单位可以为空）

c)数据属性栏的参数有：

读写类型：只读，只写，和读写

最大值/最小值: IO设备变量的最大值和最小值

初值：IO设备的初始值

变比：对IO设备的值变比（变比为1，则变量值不变等值；变比为2，则变量值为其2倍）

d）存盘属性栏和报警属性栏同上一节设备变量意义一样这里不重述了。


历史数据库

系统变量

6．数据库配置

6.3 系统变量

a）在软件左栏的点击系统变量，如下图：

b）系统变量：系统时间变量，用来获取系统时间等等，系统变量丰富而强大这里就不一一述说。


概述

7．数据库

7.1 概述

数据库由实时数据库和历史数据库组成。实时数据库自动加载了在变量配置中定义的所有的变量，包括开关量、模拟量、设备状态量、内部量，记录了变量的逻辑值、采样原值、状态和报警标识，用户可以远程连接实时数据库进行实时数据的监视，以便对异常进行及时的处理；历史数据库用来查询历史存盘数据、系统报警、控制记录和操作记录，以便分析历史数据对系统的故障进行检测 。


实时数据库

7．数据库

7.2 实时数据库

用户通过远程连接实时数据库可以对实时数据进行监视，对突发的异常进行处理，降低损失。如果要监视本机工程的实时数据，则运行本机工程后，双击实时数据库打开实时数据库窗口，点击模拟量，显示系统中所有模拟量的实时数据，如下图所示：

此时系统处于离线状态，在工程管理器中运行工程，切换到实时数据库窗口，点击连接弹出如下图所示的数据库连接窗口：

如果工程在本地pc机上，就“连接本地“，如果在远程嵌入式系统中，则输入远程ip地址，点“连接”，在连接状态处显示连接成功后，实时数据库中的数据即为系统实时采集来的数据，具有实际意义。如上图监视的为实时模拟量数据，内容包括模拟量的总线号即在实时数据库内存中模拟量区的编号，在共享内存中的位置编号，模拟量的名称、描述，逻辑值为原始值经过初始值和变比处理后的值，采样原值为从设备采集的原始值。
状态共有7个值，0表示正常，1表示上越限告警，2表示上上越限告警，3表示下越限告警，4表示下下越限告警，5表示正偏移告警，6表示负偏移告警。
报警属性中0表示不报警，1表示处于报警状态，当处于报警状态时编号前的小方块为红色，不报警显示为绿色。开关量和设备状态量监视显示如模拟量一样，这里就不再详细说明了。
实时数据库窗口菜单中除了连接以外还有一些功能操作，如连接菜单中有打印、关闭，打印即将显示窗口中的监视数据打印出来存档，关闭就是关闭实时数据库监视窗口。
帮助菜单中有帮助、关于，帮助为使用实时数据库的帮助文档，关于此实时数据库的版本。
控制菜单包括强制数据、控制执行、机构体下传。
强制数据即强制实时数据库中的逻辑值，选中要强制的数据列，单击强制数据弹出如下图所示的窗口：

在强制文本框中输入强置的数据值，点击“执行”按钮，就改变了选中列的数据值。如选中序号为1的模拟量，在上图强制文本中输入的强制的值1，点击“执行”按钮后，实时数据库中序号为1的模拟量的逻辑值变为1，如下图所示：

控制执行用于对设备中的DO、AO的控制，强制设备中DO、AO的值。包括写单个数字量输出寄存器、写单个模拟量输出寄存器、写多个模拟量输出寄存器、写多个数字量输出寄存器，点击强制执行弹出如下图所示的强制执行窗口：

命令串文本框中的TEST为固定格式，0表示内存编号，ProSetReg 1 100 50为开出串，可有设备驱动文档获得，如输入强置AO的值的命令，可强制单个或多个AO的值，如输入：6X 1 1 200，表示写单个模拟量输出寄存器的值，6X标识为写单个模拟量，第一个1为设备地址，第二个1代表该模拟量在设备中的地址，200为要给该模拟量寄存器设置的值。
开出串文本框中的TEST为固定格式，第一个0表示内存编号，第二个0表示数据库_输出量中开出串的序号，“浏览”按钮浏览选择数据库开出量的序号。


历史数据库

7．数据库

7.3 历史数据库

历史数据库中包括了对系统中的历史存盘数据、系统报警、控制记录、操作记录的查询，通过对历史数据的分析，从而检查系统故障，避免同样的错误再次发生。用户的登录、操作、控制等都记录到历史数据库中，高级别权限的用户可以查询操作、控制记录等。
要对历史数据进行查询首先必须连接历史数据库，点击本窗口的文件菜单中的“连接数据库”会弹出如下图所示的连接数据库窗口：

浏览本地磁盘选择数据库路径后，点击确定完成历史数据库的连接。
要查看历史存盘数据，双击左边的树节点下的存盘数据，弹出如下图所示的历史存盘数据时间范围选择对话框：

在开始实际设置框中设置需要查看的历史存盘数据的起始时间，在结束时间设置框设置查看数据的截止时间，点击确定后，历史数据库窗口右侧数据显示区域就会显示在设置时间范围内的历史存盘数据，如下图：

查看系统报警、控制记录和操作记录同查看存盘数据的操作一样，下图为查看控制记录后显示的数据，显示的条目包括序号、站点号、操作此数据的用户名、时间、具体控制和该用户的权限。

如要将这些记录保存下来，可点击操作菜单下的“导出为csv”，执行此命令，弹出如下的选择性保存对话框：

在对话框中可以选择保存的对象如导出选择项、导出未选择项、全部导出、导出指定的数据编号的数据行，选择好其中一项后点击确定后弹出保存对话框，输入保存的名称，保存的格式为csv，确定后完成保存。保存的文件可以用excl或文本文档打开，以供随时查阅。


概述

8．驱动监视

8.1 概述

驱动监视用于远程监视驱动的通信情况，可以对设备返回的值进行分析，以确定设备是否通讯正常。监视串口中的数据由两部分组成，一个是发送的数据，一个是设备接收到该数据的返回值，由于驱动是间隔性的不间断的向设备发送数据，所以设备也是不间断的返回数据，这样就实现了对设备的实时监视，及时的了解设备的通讯是否异常，在通讯发生异常第一时间进行检修，将工业损失降到最小。


驱动监视

8．驱动监视

8.2 驱动监视

在进行驱动监视之前，要保证系统是处在运行状态，这样驱动才能连接，在工程管理器的工程管理树状菜单中双击“驱动监视”，弹出如下图所示的驱动监视窗口：

点击“连接到驱动”会弹出驱动连接对话框，如下图所示：

在内存号中输入监视的内存编号，如果系统在本机就连接本地按钮，如果监视远程计算机在输入远程计算机ip地址，点击连接按钮，连接成功与否会在连接状态处显示。连接成功后勾选显示，在数据显示窗口就会显示实时发出的数据和设备返回接收的数据，如下图所示：

如上图勾选“16进制显示”单选框后，数据显示区的数据就会以16进制的形式显示，取消勾选会以ASCII码的形式显示；勾选“滚屏”数据可以滚屏显示；勾选“显示”数据区数据显示，取消勾选则不显示实时的数据，当然之前显示的数据会保留在屏幕上；显示下的文本框显示端口打开否；点击“清空显示”按钮清空显示区的数据；点击“显示另存为”将显示区监视的数据另存为文件保存起来；“退出”则退出驱动监视窗口。


系统内部函数

概述

9．系统函数事件

9.1 概述

QTouch嵌入式系统为用户提供了一些常用的对系统运行状态进行操作的系统函数事件，在进行工程组态时，可以在系统属性的脚本属性中直接使用这些函数事件。
下面分别介绍函数事件的用途、使用方法及实例。

1）在绘制系统中我们要选选择关联函数事件的变量并在属性栏设置关联的函数事件，如图。

2）在鼠标按下或者鼠标弹起就可以触发函数事件，在属性编辑中点击鼠标按下就可以关联函数事件，如图。

3）点击在打开画面的右边三角符号可以选择很多不同的函数事件，下一节就一一介绍它们的意义和用法。

点击新增就可以给变量关联函数事件了，也可以删除，上移，下移（注：一个变量可以添加多个函数事件)。


存盘及报警操作函数

事件脚本

9．系统函数

9.2 事件脚本

1)打开画面

事件意义：

打开一个小视图对话框。视图呈现出来左上角的x轴的坐标； y ：视图呈现出来左上角的y轴的坐标；

width ：视图呈现出来的宽度；heigh ：视图呈现出来的高度。

参数：

画面，


c语言编辑器

概述

10．c语言编辑器

10.1 概述

cEditor是一款C语言编辑器，可以用它来方便的编写适用于QTouch的C程序。可以在windows平台上同时编译生成windows和linux两个版本的应用程序。这样将大大提高程序开发的效率。
cEditor是由菜单栏、工具栏、状态栏、工程管理器以及文本编辑器组成，整个框架类似于VC。如果熟练使用过VC的人，可以很轻松的使用这款编辑器来编写自己的程序。下面将详细的讲解cEditor的使用，主要讲解如何创建工程，以及对工程的编译。

上图为cEditor的整个界面布局。与一般的软件布局保持一致，符合大家的 使用习惯。


c语言编辑器

新建工程

10．c语言编辑器

10.2 新建工程

点击菜单->文件->新建工程，会弹出以下对话框

输入工程名，选择工程路径，点击确定后，工程管理器中会创建相关的信息，系统会默认在工程中创建一个main.c的文件。并且会创建一个以main.c为标签的文本编辑区，这样就可以开始在此区编写C程序。

点击鼠标右键，可以进行如下操作：新建、添加、修改、删除。

新建：新建工程里面的一个项。

输入文件名，点击确认，工程会更新。

双击script.c，会新建一个编辑区

可以查看工程管理器旁边的函数列表，方便快捷的找到自己想要查看的函数。双击函数列表中的某个函数，光标就会定位在相应编辑区的指定函数。此功能类似于VC里面类的管理。

在编辑状态时，状态栏分三个部分组成：当前编辑的文件、当前工程的路径、鼠标所在的行列以及总行数。进行其他操作时，状态栏会显示操作的状态。


c语言编辑器

编译

10．c语言编辑器

10.3 编译

在程序写好后，下一步就是对程序的编译。
点击菜单栏->工具->编译

此时会弹出以下平台选择提示框：

选择要编译的平台，点击确定后，系统就会自动编译，此时编译器的下方会出现编译的信息窗口，信息窗口会提示编译中出现的错误信息，开发人员可以根据这些错误信息找到错误的出现的地方。

编译成功后，生成的可执行文件默认会生成到创建的QTouch的工程文件夹下。若要对编译器进行设置，可以点击菜单栏->工具->编译器设置

编译器的设置包括，windows和linux的编译器选择，可执行文件保存的路径以及执行文件的程序名。


c语言编辑器

概述

10．c语言编辑器

10.4.1 菜单栏

(1)文件

打开工程：打开以.vmp为后缀的工程。
打开文件：打开.c/.h的文件。
保存和另存为与其他的软件功能是类似的。
最近打开工程：保存最近五次打开过的工程，点击可以打开相应的工程。
最近打开文件：保存最近五次代开过的文件，点击可以打开相应的文件。
退出：退出编辑器系统。

（2）编辑

编辑菜单里面的功能与常用软件里面的功能是一样的，这里不做详细介绍。
（3）查看

打钩的表示现在已经显示在界面上，再点击此栏会在界面上消失。当工程管理器给关掉是，点击查看的工程管理器，工程管理器会重新显示出来。

主题配色：改变编辑区的背景色

选择desert的效果：

（4）格式

自动换行：当一行写满后，会自动跳转到下一行。

自动缩进：当写一些函数时，{}之类的符号会自动对齐函数的起始位置，或者类似写if(){}，{}会自动对齐if的起始位置。

自动换行：当一行写满后，会自动跳转到下一行。

选择字体：用户可以选择自己习惯的字体进行编码。

（5）工具

编译和编译器设置在前面已经介绍。

编译并运行：这是针对windows的平台而言的，将程序编译好后，可以运行程序，看一下运行的效果

重排版：可以选择自己习惯的风格对编辑区进行重拍版

函数列表：显示当前编辑区文本里面的所有函数，点击某个函数，光标会移动到相应的位置。

生成函数注释：选中某个函数，点击此功能，会自动生成相应的函数注释模板。

快速注释反注释：选中某一行，点击此功能，如果此行没有注释，则将这行给注释掉，反之亦然。

自动补全：当只记得某个函数的部分名称，点击此功能，会自动提示改函数的全称。

（6）帮助

关于：cEditor的信息

10.4.2 工具栏

工具栏是为了方便快捷的使用一些常用功能，详细的介绍参考菜单栏中介绍。


下载工程帮助文档

为了方便用户组态工程，可在windows系统平台下组态，组好的工程可以跨平台运行，可以通过网线或USB下载到运行设备中。

通过网线下载工程，在下载前先确定本机地址是否与运行设备的地址相匹配，可在系统参数的运行系统中更改本站地址，确定匹配后，点击下载，弹出下载对话框，如下图所示：

对话框中的目标地址192.168.1.15为新建工程时设置的本站地址，再次确定与嵌入式下位机设备地址匹配后，点击“确定”开始工程的下载，也可先ping下目标设备的地址是否连通后再下载，具体方法是，在XP系统下，点击“开始”，“运行”，输入“cmd”，回车，即可打开windows下的命令行窗口，在命令行窗口中输入“ping 192.168.1.15”，回车，如下图为Ping本机是否与目标设备连通：

通过USB更新工程，将已经组态好的工程文件夹复制到U盘中，将工程文件夹的名称改为ctfiles，将U盘插入HMI的串口，依次点击屏的左上角、右上角、左下角，弹出系统参数设置对话框，在对话框中点击“USB更新”按钮，便完成了工程的更新。


概述

6．数据库配置

6.1 概述

数据库配置中包设备变量，中间变量，系统变量。

设备变量，关联设备类型的变量（如：IO设备等）

中间变量，用于转换的或临时的内部变量

系统变量，系统内部的变量（如：系统时间等）


数据库内存映射

6．数据库配置

6.2 数据库内存映射

数据库内存映射是将各个设备的开关量、模拟量、设备状态分区记录在共享内存和实时数据库中，如下图所示，配置了I7000和I8000两个设备的开关量、模拟量、设备状态量在共享内存和实时数据库中的位置：

各列详细配置说明如下表：

列名 | 配置说明
序号 | 变量配置行数据序号，当点击“增加”“追加”，序号按增量1自动添加，当要对序号进行修改时，选择多行数据，右键点击递增设置递增量，所有的序号就会按递增量以选中所有行的第一行序号为基数依次递增
设备号 | 配置的设备的名称
变量类型 | 要配置的变量的类型，包括开关量、模拟量、设备状态量、内部量
设备内偏移 | 设置该变量存放在共享内存中的起始位置
总线开始号 | 设置该变量在实时数据库该变量区总线上的起始位置
总线终止号 | 设置该变量在实时数据库该变量区总线上的终止位置
启动方式 | 表示该变量在项目中的启动状态和链路属性，可选择启动或不启动，主链路或备用链路
主链路名称 | 设置主链路名称

以下为这两个设备的变量在共享内存与实时数据库中的映射关系图：

注意，Ram共享内存是由低到高的一整块内存，而实时数据库中的5个数据区地址均是从0开始。
在QTouch中从Driver采集到Ram共享内存的过程在 设备——数据分组中完成；
Ram共享内存映射到实时数据库的过程在数据库——内存映射中完成。
例如，有个ModbusTCP设备，我们希望完成如下图所示结果。

例如，有个ModbusTCP设备，我们希望完成如下图所示结果。
1.首先需要在数据分组中建立下列配置：

在上述配置中，构架了一个虚拟的DI区（0-99）和AI区（100-？）以方便认识。
2.Ram地址到实时数据库的过程是在数据库——内存映射中配置， 我们延续上一步骤在内存映射中建立下列配置：

总线开始号和总线终止号的差会决定每一组映射的数据个数。
3.完成数据映射过程。


数据库_开关量

6．数据库配置

6.3 数据库_开关量

要设置设备的每个开关量，首先在数据库_内存映射中记录了各个设备的开关量放入共享内存中的位置，放入开关量区的起始位置和终止地址，此时连续读取了多个开关量，为了详细设置各个开关量状态，将每个开关量单独列出，详细的设置其状态如：名称、1值条件、0值条件、告警方式等等。

如数据库_内存映射中所有设备的开关量个数之和为8，那么我们在数据库_开关量区增加8个开关量，如上图列出了所有的开关量，在名称列可以更改开关量的名称；描述列更改开关量的描述性文字；报警描述属性可以对报警进行标识。
1值条件设置为1时，表示开关量的值由0变为1时为正向变位，由1值变为0值时为负向变位；当1值条件设置为0时，表示开关量的值由0变为1时为负向变位，由1值变为0值时为正向变位。
0值显示表示当开关量的值为0值时画面实时关联显示的文本。
1值显示表示当开关量的值为1时画面实时关联显示的文本。
告警方式可以选择不告警、异常告警、变位告警、正向变位告警、负向变位告警。异常告警是和正常这个属性相关联的，当正常属性设为1，如开关量的值为0则表示发生了异常，当正常属性设为0，如开关量的值为1则发生了异常。变位告警即1变成了0或0变成了1则发生了变位。正变位和负变位则和1值条件相关联，上面在概述1值条件时已经描述了，此处不再赘述。
告警属性选择显示并存盘、仅显示、仅存盘。如在告警方式中设置了异常告警、变位告警、正向变位告警、负向变位告警，如果告警属性选择显示并存盘，则此开关量的告警方式会在事件信息控件中显示出来，并且报警信息会存储在报警记录历史数据库中，以便于用户在历史数据库中查询告警信息。
存盘方式可选择不存盘、变位存盘、周期存盘。如果选择周期存盘，可以在存盘时间属性设置存盘间隔时间，默认是60秒，就是间隔60秒对开关量进行一次存盘，将开关量的值存入历史数据库中的存盘数据中，以便于用户查询历史的开关量值。如果选择变位存盘，开关量就会在0变位1，或1变为0时进行存盘。
各属性详细配置如下表：

列名 | 配置说明
序号 | 开关量行数据序号，当点击“增加”、“追加”，序号按增量1自动添加，当要重新对多行数据的序号进行修改时，选择多行数据，右键点击递增设置递增量，所有的序号就会按递增量以选中所有行的第一行序号为基数依次递增
名称 | 开关量的名称
描述 | 对开关量的描述
1值条件 | 设置采集来的数据的变位方向，值为1时，开关量的值由0变位1时为正向变位，值为0时，开关量的值由1变为0时为正向变位
0值显示 | 当采集来的数据值为0时在实时关联的界面上显示的文本
1值显示 | 当采集来的数据值为1是在实时关联的界面上显示的文本
告警方式 | 设置发生异常时告警的方式，包括不告警、异常告警、变位告警、正变位告警和负变位告警
报警描述 | 对报警的描述
正常态 | 此属性同异常告警属性相关联，当正常态设为0时，若开关量的值为1则为异常告警，当正常态设为1时，若开关量的值为0则为异常告警
告警属性 | 发生告警后对告警数据的处理，包括显示并存盘、仅显示、仅存盘
存盘方式 | 数据存盘的方式，包括不存盘、变位存盘、周期存盘
存盘时间 | 数据存盘的间隔时间，即两次数据存盘的时间间隔
工程转换 | 将采集的数据进行转换，比如说取反、取余、取正弦等等
注释 | 对该数据库开关量的特殊说明s


数据库_模拟量

6．数据库配置

6.4 数据库_模拟量

在数据库_内存映射中设置模拟量放入共享内存中的位置，放入实时数据库中模拟量区的起始位置和终止地址，此时连续读取了多个模拟量，为了详细设置各个模拟量状态，将每个模拟量单独列出，详细的设置其状态如：名称、描述、单位、额定值、最小值等等。

在数据库_内存映射中连续添加32个模拟量，上图列出了8个模拟量。序号为自动生成，也可更改；为了在画面关联模拟量时易识别各个模拟量，名称和描述可改成具有实际意义的值；单位属性表示模拟量的值以何种方式计量；
额定值为该模拟量的额定大小。额定值与上偏和下偏属性相关联，三个值的大小用于确定该模拟量是否发生告警方式中的偏移告警。额定值加上正偏的值后的新值为正偏移告警的参考值，额定值减去负偏的值后的新值为负偏移告警的参考值，如上图序号为0的模拟量的额定值为4000，正偏为3000，负偏为1000，则正偏移告警的参考值为7000，负偏移告警的参考值为3000，如果采集的实时数据中模拟量的值在3000—7000之间则不发生偏移告警，如低于3000则发生负偏移告警，如高于7000则发生正偏移告警。
最小值为其最小可取的值，当采集来的模拟量的实时数据小于该最小值，改模拟量的值就会以最小值显示。
最大值为其最大取值，当采集来的模拟量的实时数据大于该最大值，改模拟量的值就会以最大值显示。
根据实际工程需要可以将每个模拟量给个起始值即零点值，模拟量在工程中的记录值为起始值与变比后的值之和；往往工程呈现给用户的值须具有一定的实际意义，而设备采集来的值只为原始值，我们需要进行按某种换算方式进行转换，通过变比和零点初值的便可对原始数据进行以一定方式的换算成具有一定实际意义的值，呈现在用户面前；
上限、上上限、下限、下下限分别标记了模拟量发生越限告警的范围。如果模拟量的值大于上限小于上上限则发生上越限告警；如果模拟量的值大于上上限的值则发生上上越限告警；如果模拟量的值小于下限的值则发生下越限告警。
正偏、负偏和额定值相关联后限定了模拟量正偏和负偏的参考值。
告警方式中有不告警、越限告警、偏移告警、上下越限告警、正负偏移告警。其中越限告警包括上越限告警、上上越限告警、下越限告警、下下越限告警，偏移告警包括正偏移告警、负偏移告警。
告警属性有显示并存盘、仅显示、仅存盘。此处的显示同开关量的显示类似，同样可将告警信息显示在基本控件的事件信息控件中。
存盘方式有不存盘、变位存盘、周期存盘。变位存盘包括发生上下越限或发生正负偏移时对模拟量的值进行存盘。
下表详细说明各个模拟量的配置属性：

列名 | 配置说明
序号 | 模拟量行数据序号，当点击“增加”、“追加”，序号按增量1自动添加，当要重新对多行数据的序号进行修改时，选择多行数据，右键点击递增设置递增量，所有的序号就会按递增量以选中所有行的第一行序号为基数依次递增
名称 | 模拟量的名称
描述 | 对模拟量的描述
单位 | 设置采集来的模拟量的计量单位
额定值 | 当前采集量规定的额定值
最小值 | 当前采集的模拟量的最小值，当采集的值小于此值，以最小值显示
最大值 | 当前采集的模拟量的最大值，当采集的值大于此值，以最大值显示
零点初值 | 设置模拟量初值，显示的值为采集值与初值的和
变比 | 将采集的数据一定的算法变换后显示
上限 | 该模拟量发生上越限告警的参考值
上上限 | 该模拟量发生上上越限告警的参考值
下限 | 该模拟量发生下越限告警的参考值
下下限 | 该模拟量发生下下越限告警的参考值
正偏 | 与额定值的和作为该模拟量发生正偏移的参考值
负偏 | 额定值减去负偏的值作为改模拟量发生负偏移的参考值
告警方式 | 设置发生异常时的告警方式，包括不告警、越限告警、上越限告警、下越限告警、正偏移告警、负偏移告警
告警属性 | 包括显示并存盘、仅显示、仅存盘
存盘方式 | 数据存盘的方式，包括不存盘、变位存盘、周期存盘
存盘时间 | 数据存盘的时间间隔，即两次数据存盘的时间间隔
工程转换 | 将采集的数据进行转换，比如说取反、取余、取正弦等等
注释 | 对该模拟量的特殊说明


数据库_设备状态

6．数据库配置

6.5 数据库_设备状态

在数据库_内存中设置设备状态量放入共享内存中的位置，放入设备状态量区的起始位置和终止地址，此时添加了多个设备状态量，为了详细设置每个设备状态，将每个设备状态单独列出，详细的设置设备状态如：名称、描述、告警方式、告警属性、存盘方式、存盘时间、注释，如下图所示：

在变量配置中添加了8个设备状态量，如上图列出了所有的设备状态，序号自动生成，也可修改；在名称列可以更改设备状态量的名称；修改设备描述；选择告警方式为告警或不告警；选择告警属性为显示并存盘、仅显示、仅存盘；选择存盘方式为不存盘、变位存盘、周期存盘。
下表详细说明各个设备状态量的配置属性：

列名 | 配置说明
序号 | 设备状态量行数据序号，当点击“增加”、“追加”，序号按增量1自动添加，当要重新对多行数据的序号进行修改时，选择多行数据，右键点击递增设置递增量，所有的序号就会按递增量以选中所有行的第一行序号为基数依次递增
名称 | 数据状态量的名称
描述 | 对数据状态量的描述
告警方式 | 设置发生异常时的告警方式，包括告警、不告警
告警属性 | 发生告警后对告警数据的处理，包括显示并存盘、仅显示、仅存盘
存盘方式 | 数据存盘的方式，包括不存盘、变位存盘、周期存盘
存盘时间 | 表示该变量在项目中的启动状态和链路属性，可选择启动或不启动，主链路或备用链路
主链路名称 | 设置主链路名称


数据库_输出量

6．参数设置

6.6 数据库_输出量

输出量是用于对设备中的DO、AO的控制，强制设备中DO、AO的值。包括写单个数字量输出寄存器、写单个模拟量输出寄存器、写多个模拟量输出寄存器等，如下图所示：

序号0所在行的配置代表设置该modbusTCP设备多个模拟量输出寄存器的值，设备型号为该modbusTCP设备，描述可写标记该操作在实际工程中的意义，数据区16X定义为写多个模拟量输出寄存器的值，地址0表示要写入的多个输出寄存器的起始寄存器在该modbusTCP设备中的地址，操作输入表示写入的值由用户从画面上的输入框输入，通常配合脚本函数!SendConV( kc , num , name )一起使用，从而达到用用户对输出寄存器进行赋值。函数!SendConV( kc , num , name )中的第一个参数kc代表开出量的序号，如与该行配置串相关联，则kc设为0；第二个参数num表示要写入的寄存器的个数；name为用户输入寄存器值的文本框的名称。
序号1所在行的配置代表设置该modbusTCP设备多个数字量输出寄存器的值，数据区的FX定义为写多个开关量输出寄存器的值，其操作为输出，其使用方法同序号0。
序号2所在行的配置代表设置该modbusTCP设备单个数字量输出寄存器的值，数据区的6X定义为写多个开关量输出寄存器的值，其操作为输出，其使用方法同序号0。
序号6所在行的配置代表强置该modbusTCP单个数字输出寄存器的值，修改描述为有代表意义的值，设备地址为此ModbusTCP的地址，数据区5X定义为强制设备中单个DO的值，数据区后的地址为该DO在设备中的地址，操作置OFF代表将DO的值置0。
序号8所在行的配置代表设置该设备多个开关量输出寄存器的值，数据区FX定义为强制设备中多个DO的值，地址表示第一个DO在设备中的地址，操作设为数值，表示设置DO的值在数值行输入，数值行的值为29 1 1 1.....,表示设置29个开关量输出寄存器都为1。
下表详细说明各个设备状态量的配置属性：

列名 | 配置说明
序号 | 设备行数据序号，当点击“增加”、“追加”，序号按增量1自动添加，当要重新对多行数据的序号进行修改时，选择多行数据，右键点击递增设置递增量，所有的序号就会按递增量以选中所有行的第一行序号为基数依次递增
设备号 | 设备的名称
描述 | 标记该配置串在实际工程中的意义
设备地址 | 该设备在总线中的地址
数据区 | 该设备开出量执行的数据区域
地址 | 开出量的地址，如果对单个开出量执行操作该地址就为该开出量的地址，如果对连续的多个开出量执行操作则该地址为这多个连续的开出量的起始量的地址
操作 | 如果开出量为单个开关量则选择置ON或置OFF以执行赋值1或赋值0操作；如果为多个模拟量或多个开关量可选择数值，并在数值列为其赋值；如果选择输入，则数值由用户从界面输入
数值 | 当操作列为数值，则在此列进行赋值，第一个数为赋数值的个数，后面为要赋值的几个量的值，值之间用空格隔开
注释 | 对该设备的特殊说明


help_draw

2．绘制系统

2.1 界面介绍

CT3000E绘图系统由以下几部分构成：菜单栏，工具条，工作区，属性区，编辑区和状态栏；

下面按构成分类分别做以下功能介绍。

2.1.1 菜单

菜单与其他Windows程序的菜单功能是相同的，让用户可以通过选择菜单项来完成某一程序功能。注意：菜单中变灰的项目，表示在当前状态下该命令无效或不支持当前选中的绘图对象。

文件

“文件”菜单包含了一组用于新建图形、打开、保存、退出等一系列操作的命令。

新建图形：创建一个新的窗口。

打开：打开已有的图形文档。

保存：保存一个窗口内容到文件。

另存为：将当前窗口复制为一个新的命名窗口，并形成文件。

存成图片：将当前窗口的内容以图片的文件类型存起来，形成图片文件。

打印：对当前创建的窗口内容进行打印。

最近文件列表：该选项记录了最近打开的图形文档，这些子菜单项是根据使用情况变化的，用户可以快速的打开最近编辑过的图形文件。

退出：退出绘图系统。

编辑

“编辑”菜单包含了一组编辑绘图对象的命令。

全选：选择当前活动图形文档中的所有对象。

拷贝：复制一个当前图形中选中的一个或多个图形对象到剪贴板中。

剪切：把当前选中的一个或多个图形对象放入剪贴板，同时清除当前剪贴的图形对象。

粘贴：把剪贴板上的内容粘贴到当前活动文档中。

视图

“视图”菜单包含了一组对创建窗口的控制命令，在当前状态下可以根据实际情况放大、缩小、全屏等一系列操作。

设计：在当前窗口内的编辑和运行模式之间的切换。

全屏：点击“全屏”第一下以全屏方式显示图形文档，点击“全屏”第二下恢复到当前编辑状态。

恢复显示：将当前图形文档恢复到默认大小。只有在图形文档在放大或缩小的情况下此按钮才有效。

放大：将当前窗口内的内容按一定比例进行放大。

缩小：将当前窗口内的内容按一定比例进行缩小。

报表查询：只有在已经存在的报表打开情况下，才能使用到该选项进行相关查询。

绘制工具

“绘制工具”菜单主要是对创建图形对象所提供的一些基本图元和超级图元。

选择工具：用于选择一个或多个当前活动图形文档中的图形对象。

矩形工具：用于在当前活动图形文档绘制一个或多个矩形。

线：用于在当前活动图形文档绘制一条或多条直线。

箭头：用于在当前活动图形文档绘制一条或多条带箭头的直线。

椭圆：用于在当前活动图形文档绘制一个或多个椭圆。

圆角矩形：用于在当前活动图形文档绘制一个或多个圆角矩形。

折线：用于在当前活动图形文档绘制一条或多条折线。

多边形：用于在当前活动图形文档绘制一条或多条多边形。其于折线的区别在于，多边形是封闭的，可以内部填充颜色，而折线不是封闭的。

贝塞尔曲线：用于在当前活动图形文档绘制一条或多条贝塞尔曲线，贝塞尔曲线也不能内部填充。

超级组对象：用于在当前活动图形文档内用其他的图元绘制出的图形加入到该超级组对象中组成的动画对象。

普通按钮：用于在当前活动图形文档绘制一个或多个按钮。

3D按钮：用于在当前活动图形文档绘制一个或多个具有3D效果的按钮图形对象。

数字编辑框：用于在当前活动图形文档绘制一个或多个数字编辑框。

下拉列表框：用于在当前活动图形文档绘制一个或多个具有下拉效果的列表框。

3D管道：用于在当前活动图形文档绘制一个或多个具有3D效果的管道图形对象。

棒条：用于在当前活动图形文档绘制一个或多个棒条。

表格实时显示：在当前图形文档中创建一个表格来显示若干个实时量的报表对象。

报警显示：在当前图形文档中创建一个listview控件，用于在运行时显示报警历史数据。

图形操作

“图形操作”菜单命令是针对选种的一个或多个图形对象进行排列的操作。

左对齐：将当前活动图形文档中两个或两个以上选中的图形对象，以基准对象左位置对齐。

右对齐：将当前活动图形文档中两个或两个以上选中的图形对象，以基准对象右位置对齐。

顶对齐：将当前活动图形文档中两个或两个以上选中的图形对象，以基准对象顶端位置对齐。

底对齐：将当前活动图形文档中两个或两个以上选中的图形对象，以基准对象底端位置对齐。

垂直居中对齐：将当前活动图形文档中两个或两个以上选中的图形对象，以基准对象的宽度的中心对齐。

水平居中对齐：将当前活动图形文档中两个或两个以上选中的图形对象，以基准对象的高度的中心对齐。

水平翻转：将当前选中的图元对象沿水平方向翻转。

垂直翻转：将当前选中的图元对象沿竖直方向翻转。

垂直等距分布：将当前活动图形文档中三个或三个以上选中的图形对象之间的垂直间隔设置为相等。

水平等距分布：将当前活动图形文档中三个或三个以上选中的图形对象之间的水平间隔设置为相等。

等宽：将当前活动图形文档中一个或多个选中的图形对象宽度设置成与基准对象宽度一致。

等高：将当前活动图形文档中一个或多个选中的图形对象高度设置成与基准对象高度一致。

等高宽：将当前活动图形文档中一个或多个选中的图形对象高度和宽度设置成与基准对象的高度和宽度一致。

拆组：将当前活动图形文档中两个或两个以上选中组合在一起的图形对象进行拆分。

窗口

“窗口”菜单主要是针对窗口进行缩小放大功能。

2.1.2工具条

文件、编辑和试图操作工具条

新建：创建一个新的窗口。与文件菜单中的新建功能相同。

打开：打开一个图形文档。与文件菜单中的打开功能相同。

保存：保存一个图形文档。与文件菜单中的保存功能相同。

打印：选择此工具条按钮可以进行打印。

退出：退出这个绘图系统。

拷贝：把当前所选中的图形对象粘贴到剪贴板中。

剪切：剪切在当前选中的一个或多个图形对象。

粘贴：粘贴剪贴板中一个或多个图形对象。

设计：选择此工具条按钮在设计状态和运行状态间进行交换。

放大：将当前图形文档按一次10%的比例进行放大。

缩小：将当前图形文档按一次10%的比例进行缩小。

恢复显示：将当前图形文档恢复到默认大小。只有在图形文档在放大或缩小的情况下此按钮才有效。

绘图工具条

矩形：用于在图形文档中绘制矩形对象。

直线：用于在图形文档中绘制直线对象。

箭头：用于在图形文档中绘制箭头对象。

椭圆：用于在图形文档中绘制椭圆对象。

圆角矩形：用于在图形文档中绘制圆角矩形对象。

折线：用于在图形文档中绘制折线对象。

多边形：用于在图形文档中绘制多边形对象。其与折线的区别在于，多边形是封闭的，可以内部填充颜色，而折线不是封闭的。

贝塞尔曲线：用于在图形文档中绘制贝塞尔曲线对象。贝塞尔曲线是不能进行内部填充。

扇形：用于在图形文档中绘制出扇形对象。

超级组对象：用于在当前活动图形文档内用其他的图元绘制出的图形加入到该超级组对象中组成的动画对象。

按钮：在当前图形文档中绘制一个或多个按钮。

3D按钮：在当前图形文档中绘制一个或多个具有3D效果的按钮。

数字编辑框：在当前图形文档中绘制一个或多个数字编辑框对象。

下拉列表框：在当前图形文档中绘制一个或多个下拉列表框对象。

3D管道：在当前图形文档中绘制一个或多个具有3D效果的管道对象。

棒条：在当前图形文档中绘制一个或多个棒条对象。

报警显示：在当前的图形文档中绘制一个listview控件，用于显示报警历史。

字体工具条

：用来设置字体类型和字体大小。

：根据电阻的大小来进行颜色设置识别。

：将当前图形文档中选中的字符串的字体设置为粗体。

* ：将当前图形文档中选中的字符串的字体设置为斜体。

：将当前图形文档中选中的字符串的字体加下划线。

：将当前图形文档中选中的字符串的对齐方式为居左对齐。

：将当前图形文档中选中的字符串的对齐方式为居中对齐。

：将当前图形文档中选中的字符串的对齐方式为居右对齐。

：将当前图形文档中选中的字符串的对齐方式为垂直居上。

：将当前图形文档中选中的字符串的对齐方式为垂直居中。

：将当前图形文档中选中的字符串的对齐方式为垂直居下。

：设置当前图形文档中字符串的颜色。

站点设置工具条

该站点工具条是用来设置站点的机组信息，可以获取系统变量及实时关联量数据库中的名称，也可以选中所有的图形对象进行统一的站点信息设置，并按选中的先后顺序进行递增排序。

：站点设置。在下拉列表中包含了10个站点，可以根据实际情况进行选择。

：在下拉列表中包含了系统变量、遥信、遥测及遥脉。

* ：按选中的多个图形对象的先后顺序递增排序。

* ：显示多个选中的图形对象的实时关联量数据库中的名称。

排列对齐工具条

：将当前图形文档中选中的图形对象前移一个。

* ：将当前图形文档中选中的图形对象置于最顶端。

：将当前图形文档中选中的图形对象后移一个。

：将当前图形文档中选中的图形对象置于最底端。

：将当前图形文档中选中的两个或两个以上的图形对象以基准对象左对齐。

：将当前图形文档中选中的两个或两个以上的图形对象以基准对象右对齐。

：将当前图形文档中选中的两个或两个以上的图形对象以基准对象顶端对齐。

：将当前图形文档中选中的两个或两个以上的图形对象以基准对象底部对齐。

：将当前图形文档中选中的两个或两个以上的图形对象以基准对象垂直居中对齐。

：将当前图形文档中选中的两个或两个以上的图形对象以基准对象水平居中对齐。

：将当前图形文档中选中的两个或两个以上图形对象以基准对象作垂直等距分布。

：将当前图形文档中选中的两个或两个以上图形对象以基准对象作水平等距分布。

：将当前图形文档中选中的两个或两个以上图形对象设置成与基准对象宽度一致。

：将当前图形文档中选中的两个或两个以上图形对象设置成与基准对象高度一致。

：将当前图形文档中选中的两个或两个以上的图形对象设置成与基准对象宽度和高度一致。

：将当前图形文档中选中的两个或两个以上的图形对象组合为一个图形对象。

：将当前图形文档中的一个组合图形对象拆分为原有的几个图形对象。

：具有旋转中心编号属性的图元进行逆时针旋转。

：具有旋转中心编号属性的图元进行顺时针旋转。

：是超级组对象的动画开始播放的一个按钮。

：是超级组对象动画循环播放的一个按钮。

2.1.3 工作区

工作区是由图形集和图元集两部分组成，是以树型结构显示的。

图形集用来显示一些已经绘制好的图形，可在新建图形文档中按要求显示当前已经绘制好的所有图形。

图元集也是一些绘制好的图形元素，用户根据绘制图形的情况添加相应的图元到图形文档中，完成整个流程的绘制。

2.1.4 状态栏

状态栏的“信息区”显示的是当前您所选择的图形元素的名称；

“100”是指图形比例；

“X178，Y430”是指您所绘制图形或选中图形的坐标位置。

2.2 绘图步骤

2.2.1 基本图元绘制

基本图元包括以下几种：直线，箭头，矩形，圆角矩形，椭圆，多边形，折线，贝塞尔曲线。

2.2.1.1 矩形的绘制

绘制过程

在菜单或者工具条上选择矩形，在编辑区内按住鼠标左键并任意拖动到合适的位置，松开鼠标左键，就完成了一个矩形的绘制。如果想再继续绘制矩形的话，同上一步操作；如果想结束矩形的绘制，那么在编辑区内任意地方点击鼠标右键，就完成了矩形的绘制，并通过矩形的属性按需求进行设置。

2.2.1.2 直线的绘制

绘制过程

在菜单或者工具条上选择直线，在编辑区内按住鼠标左键并任意拖动到合适的位置绘制出与X轴，Y轴成任意角度的直线。

在绘制水平直线和垂直直线的方法：按住Ctrl键的同时，分别以水平方向和垂直方向拖动直线，将分别得到水平直线和垂直直线。

2.2.1.3 箭头的绘制

绘制过程

如上步骤，在编辑区内拖动出一个箭头。通过在属性区内可以根据实际情况的需要对直线两端的箭头进行任意的取舍。

对于箭头，如果要改变箭头直线的颜色，需要设置线条颜色；如果要对箭头内部的颜色修改，需要设置填充颜色。

2.2.1.4 椭圆的绘制

绘制过程

在菜单或者工具条上选择椭圆，以绘制其他图元方式一样，拖动出一个椭圆。

2.2.1.5 圆角矩形的绘制

绘制过程

在菜单或者工具条上选择圆角矩形，以绘制其他图元方式一样，拖动出一个圆角矩形。可以通过设置它的属性，改变矩形圆角的大小。

2.2.1.6 折线的绘制

绘制过程

在菜单或者工具条上选择折线，在编辑区内单击鼠标左键确定折线的起始点，然后松开鼠标左键，移动至折线的第二个点的位置，单击左键确定第二点，重复此过程直到最后一点，最后在编辑区内任意位置单击鼠标右键确定折线的绘制完成。

2.2.1.7 多边形的绘制

绘制过程

在菜单或者工具条上选择多边形，以绘制折线的方法一样绘制多边形。多边形与折线具有相同的属性。

2.2.1.8 贝塞尔曲线的绘制

绘制过程

在菜单或者工具条上选择贝塞尔曲线，以绘制折线的方法一样绘制贝塞尔曲线。如果要修改曲线的形状，可以通过改变其中的任意一点来改变其形状。

2.2.2 高级图元绘制

2.2.2.1 组合与超级图元的绘制

绘制过程

在菜单或者工具条上选择相应的图元，绘制出所需的图形，选种需要组合在一起的图元，点击工具条上的“组合”按钮或者快捷键Ctrl+G，将图元组合在一起。再点击工具条上的“超级组对象”,更改其名称，然后把要组合的图形属性里“加入组”选项选为“超级组对象”的名称，如需添加脚本的，可在其属性框中双击“脚本属性”，在弹出的对话框里添加相应代码。

在设计状态下（也就是在工具条上有一条是试图工具，凹下的“设计”状态表示编辑，再点击一下，表示运行状态），是不会呈现出动画效果的，要在运行状态下， 才显示动画效果。

2.2.2.2 普通按钮的绘制

绘制过程

绘制按钮和绘制矩形的方法是一样的，在按钮的属性框里选择“文本”更改显示在按钮上的文本，选择“激活”为True，那么按钮即为运行状态，在“脚本属性”选项里可以为按钮添加需要脚本。

2.2.2.33D按钮的绘制

绘制过程

绘制3D按钮和绘制普通按钮的方法是一样的，它是以一幅3D效果的图作为按钮的背景图，可以通过属性框中的“按下图像”和“弹起图像”来丰富3D按钮，以达到最好的画面表达效果。

2.2.2.4数字编辑框的绘制

绘制过程

在菜单或工具条上选择“数字编辑框”，在编辑区内拖动出一个数字编辑框。

它在画面中是具有输入功能的元件，可以设定它的最大值，最小值和默认值，下送倍数一般为1倍，也可以相应的设置为10倍或100倍，以获得不同的单位进行编辑，也就是说，将子输入的值乘以100倍，下送到脚本及驱动程序中。

2.2.2.5 下拉列表框的绘制

绘制过程

在菜单或工具条上选择“下拉列表框”，在编辑区内拖动出一个下拉列表框。

它是具有选择功能的操作元件，通过在属性框里的“列表框编辑”选项，在弹出的编辑对话框中输入相应的“显示文本”和“命令文本”的值，如下图：

点击“确定”按钮后，在属性框中选择“激活”选项，激活下拉列表框，就可以看到显示的效果。根据选定的值与脚本一起下送到驱动程序中。

2.2.2.6 3D阴影管道的绘制

绘制过程

在菜单或工具条上选择3D阴影管道，在编辑区内绘制出图形，在属性框中“管道模式”选择“垂直”和“水平”两种模式。

2.2.2.7 棒条的绘制

绘制过程

在菜单或工具条上选择棒条，在编辑区内拖动出一个棒图来。其棒图的属性值里的“最大值”“最小值”是代表了一个棒所显示的实时量的最大值和最小值。它的顶部颜色代表着最大值，底部颜色代表着最小值，如下图：

2.2.2.8 表格实时显示的绘制

绘制过程

表格实时显示表示用一个表格来显示若干个实时量。通过“数据关联”将相关的值绑定到表格上，表格的标签我们可以通过在数据关联的对话框中把“描述”拷贝下来，在新建一个报表格，将拷贝下来的东西粘贴到新建的报表格“文本”中去。

2.2.2.9 报警显示列表的绘制

绘制过程

表格实时显示表示用一个表格来显示若干个实时量。通过“数据关联”将相关的值绑定到表格上，表格的标签我们可以通过在数据关联的对话框中把“描述”拷贝下来，在新建一个报表格，将拷贝下来的东西粘贴到新建的报表格“文本”中去。

2.3 图形的属性及脚本

2.3.1基本图元属性

属性名称 | 意义 | 使用对象
实时关联 | 对需要进行实时关联的图元进行关联 | 通用
线颜色 | 根据需要更改边框或线条的颜色 | 通用
线宽 | 设置边框或线条的宽度 | 通用
线形 | 有无线，实线，虚线，点线，点虚线 | 通用
旋转角度 | 备用 | 通用
激活 | 选择true时，图形对象处于运行状态； 选择false时，图形对象处于设计状态。 | 矩形线椭圆圆角矩形
填充颜色 | 填充区域内填充所需颜色 | 矩形箭头椭圆圆角矩形 多边形扇形
透明 | 选择true时，填充区域内无显示； 选择false时，恢复当前区域填充颜色 | 同上
文本颜色 | 设置文本的颜色 | 矩形线椭圆圆角矩形扇形
文本 | 在弹出的对话框中输入文本信息 | 矩形椭圆圆角矩形扇形
文本水平对齐 | 文本信息在当前区域内实现水平居中，水平居右，水平居左对齐方式 | 同上
文本垂直对齐 | 文本信息在当前区域内实现垂直居中，垂直居上，垂直居下对齐方式 | 同上
填充类型 | 在填充区域内以多种格式填充 | 同上
字体 | 提供多种字体 | 同上
图像 | 在填充区域内以图像填充 | 矩形椭圆圆角矩形
X，Y坐标 | 绘制图元在编辑区内的坐标位置 | 矩形线箭头椭圆圆角矩形
Z层 | 选中图元置于顶层 | 矩形线椭圆圆角矩形
宽度/高度 | 所绘制图形的宽度和高度 | 矩形椭圆圆角矩形
最大值/最小值 | 设置各图元的上限值和下限值 | 箭头折线多边形贝塞尔曲线
最大值角度 | 设置图元角度最大值的范围 | 同上
操作角度 | 备用 | 同上
旋转中心编号 | 多个点中其中一点为旋转中心的序号 | 同上
初始位置 | 备用 | 同上
左/右箭头类型 | 设置箭头类型 | 箭头
左/右箭头大小 | 设置箭头的大小 | 箭头
开始角度 | 设置扇形开始角度的度数 | 扇形
终止角度 | 设置扇形结束角度的度数 | 扇形

2.3.2高级图元属性

属性名称 | 意义 | 使用对象
实时关联 | 对需要进行实时关联的图元进行关联 | 通用
文本 | 在弹出的对话框中输入文本信息 | 通用（除了棒条）
旋转角度 | 备用 | 通用（除了统计报表）
脚本属性 | 编辑或修改按下按钮后需执行的脚本 | 超级组对象按钮 3D按钮
激活 | 选择true时，图形对象处于运行状态； 选择false时，图形对象处于设计状态。 | 按钮 3D按钮数字编辑框 报表格下拉列表框统计报表 表格实时显示
填充颜色 | 填充区域内填充所需颜色 | 按钮数字编辑框下拉列表框 3D管道棒条报表格统计报表 表格实时显示
字体 | 提供多种字体 | 按钮 3D按钮数字编辑框 下拉列表框报表格统计报表 表格实时显示
X，Y坐标 | 绘制图元在编辑区内的坐标位置 | 按钮 3D按钮数字编辑框 下拉列表框 3D管道棒条
宽度/高度 | 所绘制图形的宽度和高度 | 按钮 3D按钮数字编辑框棒条 下拉列表框 3D管道
线宽/ | 设置边框或线条的宽度 | 报表格统计表格表格实时显示
线形 | 有无线，实线，虚线，点线，点虚线 | 报表格统计表格表格实时显示
文本颜色 | 设置文本的颜色 | 数字编辑框下拉列表框报表格 统计表格表格实时显示
文本水平对齐 | 文本信息在当前区域内实现水平居中，水平居右，水平居左对齐方式 | 报表格统计报表表格实时显示
文本垂直对齐 | 文本信息在当前区域内实现垂直居中，垂直居上，垂直居下对齐方式 | 同上
透明 | 选择true时，填充区域内无显示； 选择false时，恢复当前区域填充颜色 | 同上
填充类型 | 在填充区域内以多种格式填充 | 同上
组属性 | 将选中加入组的图元进行编辑和修改 | 超级组对象
按下图像 | 设置按下按钮时显示的图像 | 3D按钮
弹起图像 | 设置按钮弹起时显示的图像 | 同上
按钮样式 | 设置选择3D按钮的外观 | 同上
最大值 | 设置在数字编辑框内输入的上限值 | 数字编辑框
最小值 | 设置在数字编辑框内输入的下限值 | 同上
小数点宽度 | 设置数字编辑框内保留小数点的位数 | 同上
默认值 | 设置在默认情况下显示的数值 | 同上
下送倍数 |  | 同上
列表框编辑 | 设置列表框里的文本信息 | 下拉列表框
边框宽度 | 设置管道边框的宽度 | 3D管道
管道模式 | 管道模式为水平和垂直两种 | 同上
棒条模式 | 棒条模式也分为水平和垂直两种 | 棒条
最大值/最小值 | 显示实时量的最大值和最小值 | 同上
背景颜色 |  | 同上
当前值 |  | 同上
计算模式 | 设置表格内数据的求和，均值，最大值 最小值，日期值 | 报表格统计报表
绘制方向 | 设置报表的显示方式是横向或纵向 | 报表格统计报表表格实时显示
开始时间 | 备用 | 报表格
表格数 | 设置表格的行数 | 报表格
比率 |  | 统计报表
小数位数 | 设置保留小数点后的位数 | 统计报表
小数点 | 设置小数点的位数 | 表格实时显示

2.3.3 脚本的编辑和使用

常用关键字

EXEC

EXEC可执行文件名称

运行一个可执行文件。

OPEN

OPEN文件名称

打开一个图形文件或曲线文件。

CONC

CONC0开出号1开出号

发出一个控制命令,所关联值为0时,发0开出号.所关联值为1时,发1开出号。

COND

COND开出号 [数字串]

发出一个控制命令 开出号为参数设置中开出的序号，通过这个开出号，系统将开出号对应的命令串下发到驱动程序中，可以带数字，也可以不带数字，中括号表示可选参数。

CONS

CONS驱动号 字符串 [数字串]

发送指定的字符串到指定的驱动程序去。

CONV

CONV变量名开出号

发送变量名指定的数据或字符串下去。

ASSIGNV

ASSIGNV变量名 =编辑元件名称1 + 编辑元件名称2 + 编辑元件名称3

对变量进行赋值，变量将获取到编辑元件的数值，针对lineedit元件。

ASSIGNS

ASSIGNS变量名 =编辑元件名称

对变量名拷贝字符串，变量将获取到编辑元件的字符串，针对combobox元件。

LOGIN

LOGIN

系统登陆

SETSYS

SETSYS

系统参数设置

RAMVIEW

RAMVIEW

查看共享内存数据

EXIT

EXIT

退出程序


help_project

1．工程管理器

1.1 界面介绍

project工程管理器由以下几部分构成：菜单栏，工具条，工作区，显示区四部分组成。

下面分别介绍各自的功能。

1.1.1 菜单

菜单与其他Windows程序的菜单功能是相同的，让用户可以通过选择菜单项来完成某一程序功能。注意：菜单中变灰的项目，表示在当前状态下该命令无效或不支持当前选中的绘图对象。

工程管理

“工程管理”菜单包含了一组用于新建工程、打开、保存、另存、属性、退出等一系列操作的命令。

新建工程：创建一个新的工程，选择此操作时，必须是未打开工程项目，如果已经建立了或已经打开一个工程项目，将提示“已经建立工程”，从而不能建立工程，此时，可以选择退出工程，重新建立一个工程项目。

打开：打开已有的工程，保存的工程有.pro工程文件，选择此工程文件即可打开这个工程。

保存：保存一个工程内容到工程文件，保存的路径为工程属性中的“工程路径”所设置的工程目录，如果这个目录不存在则建立一个新的目录，如果存在则替换掉原有的项目文件。

另存为：暂时未用到，工程是按工程目录进行保存的，因此，不需要选择另存为。

属性：选择此选项用于修改和设置工程系统参数。如果工程已经建立或已经打开，选择此命令将会打开属性对话框。

在工程属性中需要设置如下：

工程名称：设置工程的名称，这个名称将在工作区中显示出来，所有的文件都归属于这个工程之下，并生成以此命名的.pro工程管理器文件。

本机站号：在多机通讯中时需要设置，多台机在一个系统中，分别以0、1、2。。。等来设置。

工程描述：对这个工程做必要的描述信息，以使之信息更全面和清晰。

设备型号：必须选择一个产品型号，这个型号和硬件型号相一致，在细节不一致的情况下，产品型号是以显示屏的大小区分的，选择和屏大小一致的型号即可。

工程路径：设置为此工程保存文件的路径，这个路径必须设置和工程文件的实际路径一致，在保存工程文件的时候，文件将会保存在这个目录之下。

设备ip地址：这个ip地址必须和实际的嵌入式ip地址一致。

启动画面：设置嵌入式启动时的主画面。

是否组网：如果不做选择，则以下信息无效，即此嵌入式单机运行，如果选择组网，则以下信息必须设置。

远程ip地址： 设置为udp数据上送和命令接收的上位机ip地址，在和ct3000监控系统组网时，即为监控系统的通讯站地址。

遥信起、遥信数：分别设置上送的遥信起始位置和总的遥信个数。

遥测起、遥测数：分别设置上送的遥测起始位置和总的遥测个数。

遥脉起、遥脉数：分别设置上送的遥脉起始位置和总的遥脉个数。

设备状态起、设备状态数：分别设置上送的设备状态起始位置和总的设备状态个数。

最近文件列表：该选项记录了最近打开的工程项目的目录，这些项是根据使用情况变化的，用户可以快速的打开最近编辑过的工程文件。

退出：退出工程管理器。

工具

“工具”菜单包含了一组对工程文件操作的命令。

下载工程：将当前的工程文件下载到嵌入式系统中，选择此命令，将弹出下载对话框。

弹出此对话框后，在显示列表中将会显示全部工程文件信息，点击确定后，在下载进度条中显示下载的进度，下载所需要的ip地址为系统参数中所设置的“设备ip地址”，如果设置的ip地址不正确，或者不在同一个网段中，将无法下载。

上传工程：将嵌入式系统中的工程文件全部上传到操作的计算机中。选择此命令之后，将会弹出上传对话框。

弹出此对话框后，需要设置目标设备的ip地址，如嵌入式的ip地址为192.168.1.12，则将此地址输入到“目标机ip地址”中，工程密码默认为没有，并要设置上传的路径，如d:\test，系统将自动建立这个目录到本地计算机上，并将嵌入式下的所有工程文件上载到这个目录中来，上传过程将显示在进度条中。

图形绘制：选择此命令启动图形绘制系统程序。

数据操作

“数据操作”菜单包含了一组对实时数据库参数的设置、修改和删除操作。

新建数据：实时数据库的数据分为遥信、遥测、遥脉、设备状态、开出命令五种，因此，在新建数据时，先必须在工作区中选择一种数据类型，如鼠标选择了遥信，并且显示区中遥信列表，选择新建数据后，将弹出新建数据对话框。

序号：设置此数据类型中的数据序号，序号不能有相同的。

数据类型：分为遥信、遥测、遥脉、设备状态、开出，选择好数据类型之后，相应的设置框变为输入允许。

遥测/遥脉设置中初值、变比：初值为校正数据的零漂，即实时数据减去这个初值，而实时数据则是采样数据乘以此变比得到的数据。

开出设置中驱动号、命令串：设置某驱动的命令串，如对第一个驱动设置一个控制串@00WR02000001，则驱动号为0，即发动此串到第一个驱动中执行，命令串为：@00WR02000001，这个串是驱动可以识别和执行的。

遥信/设备状态设置中 0值显示、1值显示：分别对应开关量的0状态和开关量的1状态是的显示内容，在图形关联中可以将开关量关联为文本显示，此时，将显示状态串中的内容。

删除数据：选中显示区中的数据行，选择此命令后，将提示是否删除此数据，确定后将从参数中删除这个数据项。

修改数据：选中显示区中的数据行，选择此命令之后，将出现新建数据一样的对话框，所不同的是已经将行中的内容显示出来，只需要修改即可。

批量增加：在数据量很多的情况下，为加速设置，可以选择此命令，将弹出批量增加对话框。

起始序号、终止序号：分别对应数据的起始序号和终止序号。

名称：对批量数据设置一个公共的名称，名称的后面将自动增加其起始的数字序号。

数据类型：只能选择为遥信和遥测。

遥测设置、遥信设置：和新建数据中的含义一致。

驱动设置

“驱动设置”菜单为工程设置通讯参数，分为驱动参数和通讯参数。

新建驱动：用于建立一个工程驱动参数，鼠标先选中工作区中的“驱动参数”，然后选择新建驱动命令，将弹出新建驱动对话框。

驱动名称：设置驱动的名称。

共享内存编号：从0、1、2…设置起，分别对应第一个、第二个驱动等。

遥信起、遥信止、数据偏移：遥信的起始和终止是指本驱动内的数据起止，数据偏移是指这个遥信数据类型在整个实时数据库遥信总线上的偏移。

遥测起、遥测止、数据偏移：遥测的起始和终止是指本驱动内的数据起止，本驱动内，可以随意存放不同的数据类型，如可以先存放遥信，然后再存放遥测，这时遥测的起就应该跟在遥信的止后面。数据偏移是指这个遥测数据类型在整个实时数据库遥测总线上的偏移。

遥脉起、遥脉止、数据偏移：遥脉的起始和终止是指本驱动内的数据起止，数据偏移是指这个遥脉数据类型在整个实时数据库遥脉总线上的偏移。

设备状态起、设备状态止、数据偏移：设备状态的起始和终止是指本驱动内的数据起止，数据偏移是指这个设备状态数据类型在整个实时数据库设备状态总线上的偏移。

图例说明如下：

修改驱动：修改驱动弹出的对话框和新建的一致。

删除驱动：鼠标选中驱动列表中的一行，选中此命令，将提示删除此驱动。

新建通讯：用于建立一个驱动程序的通讯参数，鼠标先选中工作区中的“通讯参数”，然后选择新建通讯命令，将弹出新建通讯对话框。

驱动名称：应和驱动的名称一致，也就是说一个驱动应该有一个相对应的通讯参数。

共享内存编号：应该和驱动的编号一致，也就是：第一个驱动应该为0，序号为0，内存编号也为0。

串口号、波特率、数据位、校验位、停止位、超时：为串行通讯的参数配置，如果选择串口通讯则有效。

Ip地址、端口：为以太网络通讯参数设置，如果选择以太网通讯有效。

附加串数：设置附加串的有效行数。

Text空白区：为开放驱动设置区，在这里可以设置驱动识别的附加串。

修改通讯：弹出的对话框和新建对话框一致。

删除通讯：鼠标选中通讯列表中的一行，选中此命令，将提示删除此通讯，确认后将执行删除。

权限设置

“权限设置”菜单用于设置系统操作权限。

新建用户：用于新建一个操作用户，这个用户是指对运行系统操作的用户，鼠标先选中工作区中的“权限设置”，然后选择新建用户命令，将弹出新建用户对话框。

在这个对话框中分别输入用户名、密码和权限，其中权限分为0~9级，最高级为9，最低为0。

修改用户：和新建用户一致，修改其中的参数即可。

删除用户：鼠标选中用户列表中的一行，选中此命令，将提示删除此用户，确认后将执行删除。

报警设置

“报警设置”菜单用于设置系统报警参数。

新建报警：报警分为遥信报警和遥测报警两个选项，先在工作区中选择“报警设置”中的遥信报警或遥测报警，将会弹出报警参数设置窗口。

遥信报警对话框如下：

序号：为报警的连续编号。

关联遥信序号：为遥信报警所关联的对象的序号，其报警是根据此序号的遥信量的状态。

报警信息：为报警后显示的基本信息。

0值显示：提示状态为0时的报警信息。

1值显示：提示状态为1时的报警信息。

正常态为0：报警在遥信状态为0时不产生报警，而在报警之后，复归到0状态后显示。

正常态为1：报警在遥信状态为1时不产生报警，而在报警之后，复归到1状态后显示。

实时显示：在运行中实时显示报警，如果报警产生，将会在运行画面最下方弹出报警信息显示18秒。

保存动作记录：选择后将动作信息保存下来，用报警显示可以显示这些报警历史。

遥测报警对话框如下：

序号：为报警的连续编号。

关联遥侧序号：为遥侧报警所关联的对象的序号，其报警是根据此序号的遥侧量的状态。

报警信息：为报警后显示的基本信息。

遥测上上限、遥测上限、遥测下限、遥测下下限：为遥测量的越限设置。

实时显示：在运行中实时显示报警，如果报警产生，将会在运行画面最下方弹出报警信息显示18秒。

保存动作记录：选择后将动作信息保存下来，用报警显示可以显示这些报警历史。

修改报警：和新建报警一致，修改其中的参数即可。

删除报警：鼠标选中用户列表中的一行，选中此命令，将提示删除此报警设置，确认后将执行删除。

1.1.2工具条

工程管理器和工具显示在工具条上。

新建工程：创建一个新的工程。与工程管理器菜单中的新建功能相同。

打开：打开一个工程文件。与工程管理器菜单中的打开功能相同。

关闭：关闭一个工程文件。与工程管理器菜单中的关闭功能相同。

保存：保存一个工程文件。与工程管理器菜单中的保存功能相同。

属性：弹出属性编辑对话框。与工程管理器菜单中的保存功能相同。

退出：退出整个工程管理器。

下载：下载工程文件到嵌入式系统。与工具中的下载功能相同。

上传：上传工程文件到嵌入式系统。与工具中的上传功能相同。

绘制：打开图形绘制系统。

1.2 操作方法

1.2.1工作区操作方法

系统参数

单击“系统参数”：将在显示区中显示所有的系统参数信息。

双击“系统参数”：将启动修改“属性”对话框，可以修改系统参数，点击确定表明修改完毕，但未保存，点击“保存”，保存修改的信息。

点击右键“系统参数”：显示工程“属性设置”菜单，选择“属性”，弹出属性对话框。

图形绘制

单击“图形绘制”：将在显示区中显示所有的图形修改信息。

双击“图形绘制”：将打开图形绘制系统。

实时数据库

单击“实时数据库”：将在显示区显示所有的实时数据信息。

单击实时数据库的子项：将在显示区显示子项的实时数据信息。在子项上单击右键，将显示“新建数据”、“修改数据”、“删除数据”选项，可以选择其中的选项进行操作。

权限设置

单击“权限设置”：将在显示区显示所有的用户信息。

单击右键“权限设置”：将显示“新建用户”、“修改用户”、“删除用户”选项，可以选择其中的选项进行操作。

报警设置

单击“报警设置”：将在显示区显示所有的实时数据信息。

单击报警设置的子项：将在显示区显示子项的报警设置信息。在子项上单击右键，将显示“新建报警”、“修改报警”、“删除报警”选项，可以选择其中的选项进行操作。

驱动设置

单击“驱动设置”：将在显示区显示所有的驱动信息。

单击驱动设置的子项：将在显示区显示子项的设置信息。

在子项“驱动设置”上单击右键：将显示“新建驱动”、“修改驱动”、“删除驱动”选项，可以选择其中的选项进行操作。

在子项“通讯设置”上单击右键：将显示“新建通讯”、“修改通讯”、“删除通讯”选项，可以选择其中的选项进行操作。

1.2.2显示区操作方法

系统参数

点击右键：显示工程“属性设置”菜单，选择“属性”，弹出属性对话框。

图形绘制

未设置操作。

实时数据库

当工作区选择在“实时数据库”：未设置操作。

当工作区选择在数据库的子项：单击右键，将显示“新建数据”、“修改数据”、“删除数据”选项，可以选择其中的选项进行操作。

权限设置

单击右键：将显示“新建用户”、“修改用户”、“删除用户”选项，可以选择其中的选项进行操作。

报警设置

当工作区选择在“报警设置”：未设置操作。

当工作区选择在报警设置的子项：单击右键，将显示“新建报警”、“修改报警”、“删除报警”选项，可以选择其中的选项进行操作。

驱动设置

当工作区选择在“驱动设置”：未设置操作。

当工作区选择在报警设置的子项：

子项“驱动设置”：单击右键，将显示“新建驱动”、“修改驱动”、“删除驱动”选项，可以选择其中的选项进行操作。

子项“通讯设置”：单击右键，将显示“新建通讯”、“修改通讯”、“删除通讯”选项，可以选择其中的选项进行操作。


help_public1

系统概述

嵌入式组态系统在现代监控和自动化系统中的起着十分重要的作用。他是分层分布系统中的现地层，通过通讯接口管理和控制现地设备，如PLC、采集卡等，可作为厂级控制系统的一个节点，通过网络接口上送现地信息并接受上级控制；并可作为设备和管理者交互的界面，即人际界面功能。也可以单独使用，实现一个对象的监控。其在系统中的图示如下：

平台概述

运行在嵌入式硬件和嵌入式操作系统基础上的工业控制软件系统。包含完整的工业控制功能：具有实时数据库、软逻辑、画面组态、网络通讯、IO设备驱动，并提供完善的系统组态和二次开发工具。

硬件： 采用cirrus logic EP9315 CPU 200MHz主频，ARM920T内核，32M内存，32M Flash

软件平台：嵌入式Linux2.6内核操作系统。

嵌入式应用软件：采用qt-embedded-2.3.7开发环境。

组态应用软件：采用qt-win-3.2.1开发环境。

画面组态

支持直线、箭头线、矩形、圆角矩形、椭圆、图像、折线、多边形、贝塞尔曲线、扇形、组合图元、超级组合等，普通的图元可以组合成复杂的图元，图元又可以组合成超级图元形成动画等。

支持普通按钮、3D按钮、数字输入框、列表框、管道、棒条、实时表格、报警列表等多种控件。

工程管理

提供高效的工程参数设置程序，所有参数设计简单、条理清晰，有利于快速的组建工程系统。

具有系统参数设置、远程通讯参数设置、实时数据设置、权限设置、报警设置、驱动设置等。所有的参数都保存成xml格式文件。

集成了上传/下载工程，直接将组建好的工程项目下载到嵌入式系统中，也可以直接将嵌入式系统的参数上传到计算机上来。

驱动支持

支持标准串行总线(如RS232/485等)、网络(如以太网、现场总线等)等通信方式。

灵活的驱动设计方案，用户可自己增加专用驱动程序，提供windows环境的调试编译手段。

可同时允许10个并行的驱动设备通信。

内置Modbus、TCP/IP、等多种PLC等通信协议。

报警功能

支持模拟量高低限报警、开关量报警等报警方式。

提供实时报警窗口显示。

提供报警历史查询功能，最多可以永久保存200条报警记录。

装置介绍

真彩TFT ， 64K颜色；

亮度250cd/m2 (LED BL unit,25oC 24小时使用，至少可维持50,000小时)；

可支持语言中文: (GB2312-80 codes) 简体中文字符 / 英文文字；

4线电阻式触摸面板

4MB NOR FLASH / 32M NAND FLASH

32M SDRAM

COM1 、COM2 RS-232 ；COM3 RS-232/RS-485(软件切换）

1个IEEE802.3, 10/100M自适应网络

2个USB2.0 Host (支持数据导入/导出/键盘/鼠标/打印等

电气特性

额定电压DC24V允许电压范围DC15V 至 DC30V

消耗功率20W 以下

抗电压冲击AC1000V/20mA/1分钟(和FG端子之间电压)

绝缘电阻DC500V 10MΩ以上(和FG端子之间电压)

环境特性

抗震性能符——IEC61131-2 标准

抗干扰性能——干扰电压: 1000Vp-p;干扰频宽: 1μs;持续时间: 1ns

抗腐蚀性能——无腐蚀性气体

抗静电性能——6kV ( EN 61000-4-2)第三级安全规格认证EN55011 CLASS A

联系方式

联系人：陈涛

联系电话：13554354265


发电厂自动化系统

发电厂的自动化系统已普遍采用分层分布控制系统，其功能也已覆盖发电机、变压器、输电线路、辅机、闸门等诸多方面。每一个监控对象由一个现地控制单元来完成现地的监控功能，所有的现地监控单元通过以太网组成厂站级控制系统

现地控制单元管理单一的对象，如发电机单元控制系统，变压器单元控制系统，闸门单元控制系统等，现地单元运行ct3000e嵌入式系统，运行人员可以通过触摸屏实现控制和监视功能。所有的单元控制通过以太网组成全厂的控制系统，在距离较远的情况下采用专用光纤组成光纤以太网，并可以组成双以太网，实现热备功能

厂级控制系统采用多工作站模式，实现热备，运行ct3000监控组态软件，实现全厂的监控功能，并且具有统计报表，历史数据记录，实时告警，操作记录，事故分析，曲线分析等等功能


组网设置帮助文档

组网设置是用在两台HMI进行组网监视同一条总线上的设备信息的场景下，其目的是防止HMI与设备连接出现故障，从而间断了实时数据的采集。采用双机进行组网，在主链路出现故障时，可以迅速启动备用链路，可不间断的实现实时数据的采集。如果没有此需要，在新建工程时可以不用对组网进行设置。如需要进行双机热备，我们就需要对其进行设置，如下图所示为双机热备模拟图：

正常情况下主链路启动，实现与设备的通讯，采集设备的数据，显示在主机HMI上，从机通过网线与主机相连，通过心跳探测主链路是否通讯正常，如果主链路通讯异常不能实现通讯，则从链路启动，从机变主机，从链路变为主链路，之前的主机从现在的主机处取数据并与其同步，从而实现了双机热备。

双击“组网设置”，显示区会弹出如下图所示的组网设置对话框，显示当前工程的组网设置。

采用双机热备则勾选“双机热备”单选框，在本站模式下，选择本站为主站，还是从站，如果选择的是主站，则输入从站ip地址，如果选择的是从站，则输入主站的ip地址， 心跳探测间隔为从机监测主机是否通讯正常的时间间隔，数据库同步时间为从机从主机处获得数据同步的时间间隔。


运行系统帮助文档

新建一个工程文件。

点击“工程”菜单下的“新建工程” 或点击工具栏“新建”按钮或键入快捷键Ctrl+N。 执行此命名，弹出如下所示的工程设置对话框：

1.工程名称：在“工程名称”输入框中输入工程名称，如Project，这个名称将在工作区中显示出来，所有的文件都归属于这个工程之下，并生成以此命名的.pro工程管理器文件,即Project.pro。

2.工程描述：在“工程描述”输入框中输入对工程的描述，以便了解工程。

3.工程路径：选择工程保存的路径，此路径必须包括具体的文件夹，如：D:/工程，可在新建工程前先在本地磁盘建一个文件夹，在保存工程文件的时候，文件将会保存在这个文件夹下。

4.产品型号：选择一个产品型号，这个型号和硬件型号相一致，在细节不一致的情况下，产品型号是以显示屏的大小区分的，选择和屏大小一致的型号即可。设备型号默认为QT56MG，下拉框中列出了一些设备型号如：QT56MG、QT70PW、QT100MG、QT100PW、QT120MG、QT150MG、PC等，根据自己设备的型号，选择此处型号。其中QT56MG表示5.6寸的符合工业规范的金属材质的HMI，QT70PW表示7寸的塑料材质的宽屏HMI，其它屏大小为10寸、12寸、15寸；PC表示组态好的画面在PC上运行。

5.本站站号：输入本站号，在多机通讯中时需要设置，多台机在一个系统中，分别以0、1、2…..等来设置。

6.启动画面：输入启动画面名称，在进行模拟或运行时，此画面将作为首页启动显示。

7.本站地址：设置本站ip地址，这个ip地址须与嵌入式设备ip地址一致，在工程下载和上传对话框中会显示此ip地址，此地址也是其它远程pc访问嵌入式设备的标识。


用户权限设置帮助文档

在工程处于打开的状态，双击“用户权限”，显示区会弹出如下图所示的对话框：

单击“添加用户”用于新建一个操作用户，这个用户是指对运行系统可操作的用户，在新增的一行表格中双击每个单元格依次输入序号、姓名、密码、权限和备注，其中权限分为0~9级，最高级为9，最低为0，输入好后点击“确认”，一个新的用户便新建成功。如果要修改某个用户的信息，鼠标点击该用户的所在行，如要修改密码，则双击该用户密码这一列，让其变成可编辑状态，然后对其进行修改，修改完成后保存即可。用户权限体现在整个系统中，如设置某个按钮的权限值为8，则只有当登录用户的权限值大于等于8该按钮则可以触发使用。


事件脚本

9.系统函数

9.2 事件脚本

打开画面

事件意义：打开一个drw视图文件，并作为当前视图，此视图需在画面编辑的时候事先设定。
参 数：画面，为drw视图文件的名称，以.drw结尾。

打开对话框

事件意义：打开一个小视图对话框。视图呈现出来左上角的x轴的坐标； y ：视图呈现出

来左上角的y轴的坐标； width ：视图呈现出来的宽度； heigh ：视图呈现出

来的高度。

参 数：画面，为小视图对话框的名称，以.drw结束；

X坐标，为视图呈现出来的x轴的位置；

Y坐标，为视图呈现出来的y轴的位置；

宽度，为视图呈现出来的宽度；

高度，为视图呈现出来的高度。

打开模式对话框

事件意义：打开一个小视图对话框。视图呈现出来左上角的x轴的坐标； y ：视图呈现出

来左上角的y轴的坐标； width ：视图呈现出来的宽度； heigh ：视图呈现出

来的高度。

参 数：画面，为小视图对话框的名称，以.drw结束；

X坐标，为视图呈现出来的x轴的位置；

Y坐标，为视图呈现出来的y轴的位置；

宽度，为视图呈现出来的宽度；

高度，为视图呈现出来的高度。

变量赋值

事件意义： 给指定的变量赋值。

参 数：变量，指定的变量（中间变量和系统变量的备用量即没有被占用的变量）

值，给指定变量赋的值

变量输入赋值

事件意义： 给指定的变量赋值。

参 数：变量，指定的变量（中间变量和系统变量的备用量即没有被占用的变量）

输入，用输入框的值给指定变量赋值 。

变量01切换

事件意义： 使变量的值在0和1之间切换

参 数：变量，指定的变量（中间变量和系统变量的备用量即没有被占用的变量）

系统变量赋值

事件意义：给系统变量赋值

参 数：变量，指定的变量（系统变量）

值，赋给系统变量的值

系统变量输入值

事件意义： 给系统变量赋值。

参 数：变量，指定的变量（系统变量）

输入，用输入框的值给指定变量赋值 。

修改报警参数---------------------------------------------------------------------------

变量值自增/变量值自减

事件意义： 指定的变量以给定的值增加/减少。

参 数：变量，指定的变量（中间变量和系统变量的备用量即没有被占用的变量）

值，指定要增加/减少的值

输入框自增/ 自减

事件意义： 指定的输入框以给定的值增加/减少。

参 数：输入框，图元元件（在参数设置的图元中选择输入框元件）

值，指定要增加/减少的值

变量bit位强制

事件意义： 指定的变量值强制1或者0。

参 数：变量，指定的变量（中间变量和系统变量的备用量即没有被占用的变量）

值，强制的值（1或者0）

下发控制

事件意义：给指定的变量下发控制值。

参 数：变量，指定的变量（IO变量）

个数，下发变量的个数

值，给下发变量的值（下发多个变量值需要英文逗号隔开）

下发输入值

事件意义：给指定的变量下发控制值。

参 数：变量，指定的变量（IO变量）

个数，下发变量的个数

输入框，图元元件（下发多个输入值需要英文逗号隔开）

下发变量值

事件意义：把指定的变量值下发。

参 数：个数，变量的个数

变量，指定的变量（IO变量）

下发系统变量

事件意义：把指定的系统变量值下发。

参 数：个数，变量的个数

变量，指定的变量（系统变量）

下发WORD值 /下发FLOAT值

事件意义：下发一个指定模式的WORD类型(或者FLOAT类型)的值

参 数：变量，指定的变量（IO变量）

个数，变量的个数

模式，模式1或者模式2

（模式1数据地位在高地址数据高位在低地址）

（模式2数据地位在低地址数据高位在高地址）

输入，输入框元件的值

注：下发是一个 WORD类型（或者FLOAT类型）的值 需要2个输入框的值组合成WORD类型

（或者FLOAT类型）

用户登录

事件意义：打开用户登录对话框。

用户退出

事件意义：退出当前的用户的登录，即撤销当前用户所具权限。

修改密码

事件意义：修改已存在用户密码。

参 数： 用户名，已存在的用户名

密码，修改后的新密码

级别，用户权限（关于权限请看最下面权限的注释）

注释，提示信息

打开系统设置窗

事件意义：打开系统设置窗设置系统的参数

退出

事件意义：退出系统

关闭弹出窗

事件意义：关闭打开的窗口

绘制画面内窗体

事件意义：绘制画面窗体。视图呈现出来左上角的x轴的坐标； y ：视图呈现出来左上角的y轴的

坐标； width ：视图呈现出来的宽度； heigh ：视图呈现出来的高度。

参 数：画面，为小视图对话框的名称，以.drw结束；

X坐标，为视图呈现出来的x轴的位置；

Y坐标，为视图呈现出来的y轴的位置；

宽度，为视图呈现出来的宽度；

高度，为视图呈现出来的高度。

设置查询起始日期

事件意义：设置查询起始日期

设置查询起始日期

事件意义：设置查询起始日期

设置历史报表查询方式 -----------------------------------------------------------

事件意义：设置历史报表查询方式

参 数：模式

设置历史曲线查询方式 --------------------------------------------------------

事件意义：设置历史曲线查询方式

参 数：模式

设置查询前推时间 -----------------------------------------------------------

事件意义：

设置实时曲线可视 -----------------------------------------------------------

事件意义：

设置历史曲线可视 -----------------------------------------------------------

事件意义：

清除实时报警

事件意义：清除实时报警

事件查询模式

事件意义：事件查询模式 -----------------------------------------------------------

参 数：模式

打印

事件意义：打印

打印当前报表

事件意义：打印当前报表

输入框掉电保持 -----------------------------------------------------------

事件意义：

启动键盘变量赋值 -----------------------------------------------------------

事件意义：

播放声音文件

事件意义：播放声音（支持的文件格式有--------------------）-----------------------------

设置系统IP

事件意义：设置系统IP

删除之前的存盘数据

事件意义：删除之前的存盘数据

删除之前报警的数据

事件意义：删除之前报警的数据

增加配方 -----------------------------------------------------------

事件意义：

参 数：

增加输入配方 -----------------------------------------------------------

事件意义：

参 数：

删除所选配方 -----------------------------------------------------------

事件意义：

参 数：

读出配方数据 -----------------------------------------------------------

事件意义：

参 数：

读出配方数据到输入框 -----------------------------------------------------------

事件意义：

参 数：

修改配方 -----------------------------------------------------------

事件意义：

参 数：

启动执行程序

事件意义：启动一个可执行文件。

参 数：程序名称（为可执行文件的绝对路径并包含名称。）

表达式 -----------------------------------------------------------

事件意义：